Dodge SRT Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
61 Posts
Discussion Starter · #1 ·
I have a problem where when I get the car into 3rd gear after 2nd gear, it'll drop down from 4K RPM's all the way to about 1,500 RPM's. The car still accelerates in 3rd gear but only when the gas is to the floor and it's still very sluggish. I feel like it picks up a bit once it gets up to 2K RPM but it's still very slow to accelerate in 3rd gear.
 

·
Registered
Joined
·
2,198 Posts
I have a problem where when I get the car into 3rd gear after 2nd gear, it'll drop down from 4K RPM's all the way to about 1,500 RPM's. The car still accelerates in 3rd gear but only when the gas is to the floor and it's still very sluggish. I feel like it picks up a bit once it gets up to 2K RPM but it's still very slow to accelerate in 3rd gear.
Weird.

Sent from my SM-G988U using Tapatalk
 

·
Registered
Joined
·
4,982 Posts
I have a problem where when I get the car into 3rd gear after 2nd gear, it'll drop down from 4K RPM's all the way to about 1,500 RPM's. The car still accelerates in 3rd gear but only when the gas is to the floor and it's still very sluggish. I feel like it picks up a bit once it gets up to 2K RPM but it's still very slow to accelerate in 3rd gear.
Try resetting the PCM:
1. disconnect battery -ive terminal
2. press brake pedal a few times
3. reconnect -ive terminal
4. drive carefully (no WOT) for 100 miles.
 

·
Registered
Joined
·
61 Posts
Discussion Starter · #5 ·
Check for boost leaks, i bet you have a pretty big one somewhere.
Why would it only be in 3rd gear though? And my boost gauge shows that it's getting boost but full throttling just doesn't accelerate much and it just drops straight down to 1500K RPM when shifting into 3rd gear from 2nd. I still have yet to reset my PCM like Simon said so I'll let you know.
 

·
Registered
Joined
·
61 Posts
Discussion Starter · #6 ·
Try resetting the PCM:
1. disconnect battery -ive terminal
2. press brake pedal a few times
3. reconnect -ive terminal
4. drive carefully (no WOT) for 100 miles.
Just now got around to this and I think this helped. If I'm correct, I could tell the PCM was reset because the check engine light was flashing at me off and on until I started the car the first time again. In 3rd gear, it dropped to only 2500 RPM's from 4K RPM's in 2nd gear instead of dropping to 1K RPM's no matter what RPM it was in 2nd gear before the reset. And instead of having to floor it and it barely accelerating at all, it actually pulls in 3rd gear. Thanks!
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top