Dodge SRT Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
2,663 Posts
Discussion Starter #1
I guess I shouldn't complain, there are no codes going off and it has been going for 300 miles since I put in S1 and leak tested, but the last 2 days I have been driving with occasional romps up to 10 psi at most as needed. Babying the car. Today in 5th at 75, floored it pegs the needle(20+) and falls to 17-18 and has a bit of shudder. Tried 4th at 65 and same thing boost hits 20+ then goes to 17-18 with a touch of shudder and stays there as long as I keep on it. Is this the timing? Or too much gap?

NGK 4306's at 0.045, do I need to shrink that gap? 0.040?
 

·
Premium Member
Joined
·
674 Posts
Gap them to 35 but thats really not the problem. its the wga. Its going to do the same thing no matter what you do. I have stage 2 and a bc and i spike 22-23 (in know there no point just hot air at that point but thats why i hold 20 till 5800) and i still fall back to 15-18 depending on what gear im in. In fourth and fifth it hold 19-20 untill almost redline then it drops.
 

·
Registered
Joined
·
2,663 Posts
Discussion Starter #3
So leave it and deal with it....that is the verdict?
I can do that, if that is what you are saying.

Will adjust the plugs though...
 

·
Premium Member
Joined
·
674 Posts
Yup thats what im saying and probally anybody thats going to read this thread. :)
 

·
Registered
Joined
·
2,663 Posts
Discussion Starter #5
Okay using Blackbird's suggestion, I lowered the gap to .037 and the bump sensation is 90% gone now. I am happy with the way it is. I did order a set of Champion 570's today and will tamper with them later.....
 

·
Registered
Joined
·
4,251 Posts
FLSRT-4 said:
Gap them to 35 but thats really not the problem. its the wga. Its going to do the same thing no matter what you do. I have stage 2 and a bc and i spike 22-23 (in know there no point just hot air at that point but thats why i hold 20 till 5800) and i still fall back to 15-18 depending on what gear im in. In fourth and fifth it hold 19-20 untill almost redline then it drops.
Just a question, do you have a wideband of any sorts?

What do you think your timing is doing?:eeeek:
 
1 - 8 of 8 Posts
Top