Dodge SRT Forum banner

1 - 20 of 21 Posts

·
Premium Member
Joined
·
4,869 Posts
Discussion Starter #1
Just as the title says my friend in the 1st gen neon is racing a 540whp cobra from around a 40ish roll to almost the end of 4th gear. As far as mods on the 1st gen neon with the swap it has aftermarket turbo, big intercooler, clutchmasters stage 4 clutch, manual boost controller, stage 1 injectors, return fuel line kit, exhaust, welded spider gears in the tranny. As far as what kind of turbo we still are unsure of what kind it is. I think its a 60-1 trim turbo from AGP, but richard(owner of car) says its a GT40 because thats what he has searched and found out about the car.

Right now the car fully spools at 4600rpm, but it is not hooked up correctly. When he got the car it had no blow off valve on it, the boost controller is hooked up only using the bottom evolution nipple(top one isnt even being used...just open), the pcv valve is so loose on the valve cover that it when doing a boost leak test it leaks out from there, etc. So far a bov has been put on the car, but the rest is how it is. Soon we will be ordering a ball and spring boost controller so we can hook up the lines correctly. We hooked it up how it should be with the manual boost controller completly shut off and when he got on it in 3rd the boost shot up to 23psi. Funny thing is that it was fully spooled at 3800rpm instead of the 4600 is does on the old way. So got to get rid of the bleed controller and get a ball and spring. With it spooling up this quick hooked up how its suppose to be leads me to believe its not a GT40, but what is anyone elses thoughts on this?

Well anyhow as far as the mods on the cobra are:
blowzilla(2.4l kenny belle supercharger), long tubes and full exhaust, pulleys, etc...making it put down 540whp right now on a mild tune. Once he finished more things its going to be tuned for over 600whp.

Well enough of the talk here is the video. Mainly the only two worth watching are the 1st 2 races. The rest of the video is kinda of just driving around...sorry I didnt make the video and yes I know it needs to be edited. Well here it is...

http://videos.streetfire.net/video/8A8D0208-9FEC-4CA4-B778-4B1CC785EC23.htm
 

·
Registered
Joined
·
588 Posts
If any of you unfamilar with the car.. this is the one that I bought from guhfluh! He had it at the last 2 nationals i do believe? As vschaos (kevin) stated.. I was told it was an agp gt 40 kit... Just lookin to hear everyones thoughts! Here is what guhfluh (glynn) posted on another site statin what the car has!

"SRT intercooler, complete engine, hubs/knuckles, brakes, wheels, tires, complete wiring harness, cluster, VTSS/SKIM, column and shroud, steering wheel, front and rear seats, center console, shifter, remote trunk latch popper thingy, windshield wiper motor and arms, antenna, pedals, rearview mirror, GT40 turbo and AGP manifold, Turbonetics EVO wastegate, 3" turboback MPx exhaust w/ Maxxfab 3" O2 coupler, modified Walbro 255, -6an stainless braided feed, Mallory 1:1 adjustable FPR, Lorenzo fuel rail, -8an and -6an stainless braided return, Earl's fittings, Summit glycerin filled fuel pressure guage on rail, PLX M-300 wideband, Autometer 30lb boost guage, Autometer SRT pyrometer, dual pod a-pillar mount, CM stage 4 pressure plate, Clutchnet brass 6-puk clutch, DSS stage 3 axles, Dropzone N1 full coilovers, Energy Suspension full bushing kit" Only thing I added was some better tires, and a bigger intercooler so far, and as of yesterday a bov!

Boost was set at a moddest 15psi, No fuel managment at all really, just the a/f gauge, mbc, and fpr! it would sneak down into the 10's and lean itself out around 12.0 that night! On the 15psi.. I figure I am puttin down around 260whp.. but I want to dyno it, to find out for sure! anyways open for comments! thanks RICHARD
 

·
Registered
Joined
·
588 Posts
No comments on the srt swapped 1st gen runnin 15psi.. racin a 540 kenne belle cobra? U guys are no fun! Just watch the 1st 2 races.. thats all! The rest of the video is alright!
 

·
Registered
Joined
·
7 Posts
what a sleeper. the unknowing would get caught really off-gaurd. i love these swaps. You should be putting out more than 260 if you kept up with that 540hp cobra. You have any pics of this car, in and out??

very nice 1st gen. :clap:
 

·
Registered
Joined
·
588 Posts
95Talon eSi said:
what a sleeper. the unknowing would get caught really off-gaurd. i love these swaps. You should be putting out more than 260 if you kept up with that 540hp cobra. You have any pics of this car, in and out??

very nice 1st gen. :clap:
Pics of the car.. are in the sig!
 

·
Registered
Joined
·
588 Posts
addictedtosin said:
whats with the dancing gay chinese guy?
That guy is poppin it! :rofl: :lol: :rofl: :rofl:
 

·
Registered
Joined
·
588 Posts
NA 148DOHC said:
You know I got Love for the 1gens :thumbsup:
Yeah got to have love for them! But mine isnt exactly runnin right, everytime I fix one thing I find something else wrong with it! As of right now its leakin around the bov I just installed,( bought it from someone, no gasket, metal on metal... didnt seal.. soooo gonna weld it on there! :eveilgrin)... and after sealin up the pvc valve... I have found that I have a leak on the drivers side of the engine, in the intake manifold gasket! I am tryin to get it ready for the up and comin race day april 9th! Got the slicks mounted today, ball and spring mbc, and checkvalve on the way.. Get everything sealed up nice and tightly! And hopefully run some low 12's.. if not break 11's on 15psi! I will have some 100+ So if I have to throw that in and turn the boost up a little I will :eveilgrin!! But its runnin pretty strong.. video shows it.. but I did a boost leak test on it the day before and it would only hold like 5psi :stab:, So I am hurtin for power! But I held my own against a 540whp cobra! Hopefully within the next week or 2 I can get everything sealed up and runnin right.. and I will have to race the cobra again! If not.... Then Rc 750's are sittin in the closest (as of today), so who wants to donate me a fuel managment system :lol:
 

·
Registered
Joined
·
7 Posts
I just see red Xs :(.

same car thats in Showoffs/pictures forum, then i seen it. very well done. Except for all the little engine quirks that are wrong. Fix all that and that things gonna scream. :eeeek:

As for the "poppin chinese guy" :rofl: :rofl: should try for the next Byonce vid. :lol:
 

·
Registered
Joined
·
588 Posts
No I have not posted any pics of it on here, just the website! I took the link from the www. and it worked fine for me so I dont know? But the car is the lavish blue color.. with the whole front back black! (brand new front end), with the srt wheels on the outside!
 

·
Registered
Joined
·
1,742 Posts
I am impressed with the 1st gen staying right with that Cobra. Those Cobras are no joke, and with those KenneBell blowers they are quick as shit. Good job of hanging with that monster.
 

·
Registered
Joined
·
588 Posts
PocketViper said:
I am impressed with the 1st gen staying right with that Cobra. Those Cobras are no joke, and with those KenneBell blowers they are quick as shit. Good job of hanging with that monster.
Well I am addin a few things to the car, and sealin everything up! I just found out last night that I have a leak around my intake manifold! Its whistlin at me now! So once I get everything sealed up.. and add the couple things that should be here early next week! So be on the look out for maybe a couple more videos between me and him or another one!
 

·
Premium Member
Joined
·
1,786 Posts
It's a "GT40" Stage five, T350 wheel blah, blah... You can't guess just by looking at a turbo housing what's in it.

http://www.srtforums.com/forums/showthread.php?t=44052&page=3&pp=15

It's "Lapis Blue" or "Smurf blue" as I call it.

You had asked about the pump mod. No, I originally had it done, but it kept leaking, so it is now installed in a stock module.

The boost controller is not hooked up wrong. In order to utilize the top nipple you need a different controller.
 

·
Registered
Joined
·
588 Posts
guhfluh said:
It's a "GT40" Stage five, T350 wheel blah, blah... You can't guess just by looking at a turbo housing what's in it.

http://www.srtforums.com/forums/showthread.php?t=44052&page=3&pp=15

It's "Lapis Blue" or "Smurf blue" as I call it.

You had asked about the pump mod. No, I originally had it done, but it kept leaking, so it is now installed in a stock module.

The boost controller is not hooked up wrong. In order to utilize the top nipple you need a different controller.
Well thanks for the info Glynn I appreciate it! Sorry to bother you if I did. It was just some questions we had been wonderin about, I figured I would ask what wheel it had in there so we could get this one settled! But I ordered the ball and spring mbc and a checkvalve, Both of which will be here in the next couple of days! The intake mani developed a leak on the drivers side.. underneath the top bolt.. it looks like you tryed to use 2 gaskets to seal it, and it blew a space underneath both of them! So we took that off today... gonna port it out a little.. might as well while its off... take the rfl bov off and seal it up tight.. then put it all back together and check for leaks! Hopefully everything comes back fine.. get it semi tuned to run durin the day and take it out there on the slicks to see what I can do before I rip the suspension off of it and replace it!!!

Hopefully I can get close to the times you have in the sig.. if not I will always have a little 100+ and the twist of a screw to turn it up a bit! :thumbsup: We will see come april 9th! thanks again for the post Glynn
 

·
Registered
Joined
·
588 Posts
98srt2dr. said:
nice, im thinkin about the fully built twin kit for my swap since its 1500 wich sounds cheaper then a lot of the big turbo kits :readclose

So did you get to run your car yet? or was the date still pushed back and you could not do it!
 

·
Premium Member
Joined
·
1,786 Posts
project95rebuild said:
it looks like you tryed to use 2 gaskets to seal it, and it blew a space underneath both of them!
Strange...
I didn't use two gaskets on purpose. Sure it didn't separate when removed? I've seen them stick to both the head and mani and peel in half...
 

·
Registered
Joined
·
588 Posts
guhfluh said:
Strange...
I didn't use two gaskets on purpose. Sure it didn't separate when removed? I've seen them stick to both the head and mani and peel in half...
I did not take a very close look at it.. the gasket still looks good.. its just blew out on the driver side bottom.. suckin air very bad! So bad it was whistlin at me! But it looked like 2 different gaskets to me, one on top of the other.. because on that side it was a little offset... Unless the gaskets come like that? Dunno since this is the first time pullin it off! All I know is it blew out on the bottom.. so I took it off and am gonna port it out a little, put it back together seal everything up... and run it on sunday.. see what happens?
 
1 - 20 of 21 Posts
Top