Dodge SRT Forum banner
1 - 20 of 34 Posts

·
Registered
Joined
·
4,074 Posts
Discussion Starter · #1 ·
My car: 2004 Dodge srt-4
stock motor mounts(no inserts), stage0, 3" turbo back exhaust, injen intake, Safc, 750cc injectors, agp wga, 18" ADR model flite 10 wheels with Toyo Proxes 4 225/40/18, mopar short shifter.

the track: New England Dragway

the times:
1st run:
60'...2.166
330...5.659
1/8...8.544
Mph...86.03
1000...11.024
1/4...12.941
mph...105.53

2nd run:
60'...2.159
330...5.629
1/8...8.488
mph...86.76
1000...10.945
1/4...13.051
mph...106.84

3rd run:
60'...2.000
330...5.461
1/8...8.329
mph...86.39
1000...10.806
1/4...12.928
mph...105.88

4th run:
60'...1.847
330...5.640
1/8...8.628
mph...83.83
1000...11.153
1/4...13.316
mph...103.51

5th run:
60'...2.034
330...5.526
1/8...8.419
mph...85.87
1000...10.916
1/4...13.057
mph...105.34
 

·
Registered
Joined
·
5,204 Posts
12's with street tires!!! Awesome man!!!
 

·
Registered
Joined
·
4,074 Posts
Discussion Starter · #4 ·
sweet thanks man
 

·
Registered
Joined
·
626 Posts
yeah that's awesome...i always wondered if 750cc injectors and n s-afc would work with stage 0...thanks for clarifyin that...awesome times man!

haha but what happened to the 4th run...fastest 60ft. but slowest ET/trap
 

·
Registered
Joined
·
4,074 Posts
Discussion Starter · #11 · (Edited)
myprojectb13 thanks for the correction on the sig... and as for that run with my 60' i missed 2nd cuz i was so shocked with the launch.... i got nervous. damn it! oh and laloosh u can ask srtgurl and nivo if you dont believe that i ran a 1.84 60' on 18 in wheels wrapped with 225/40/18 toyo proxes 4 tires, cuz they were there too. my shift points remain about the same 5800-5900 except i carry out 2nd till 6000 sometimes.
 

·
Registered
Joined
·
733 Posts
I went up against Kotu when he got his 1.8... I cut a 2.1 60ft and he flew by me pretty good, even with the 2nd gear mis-shift... it's uncanny and hard to believe, I didn't believe my own eyes, but he's a real good driver.

Edit: Traction was sick that day, was test and tune, so was bunch of big beasts with monster slicks laying down some sticky rubber for us... 2.2s are usually the best I can get, but kept getting 2.1s with ease, and not even launching that hard, not much tire spin, and no wheel hop.
 

·
Registered
Joined
·
7,943 Posts
Cracked-Out Neon said:
I didn't believe my own eyes, but he's a real good driver.
.
Funny thing is too I believe he told me that he had just learned last year how to drive a stick:rofl:
Ive driven with him in his car and yes its fast and he can definitely drive good, he gave a good smackdown on some ridiclulous Civic Ricer.
 

·
Banned
Joined
·
3,210 Posts
why 750's on a stock turbo?
 

·
Registered
Joined
·
3,725 Posts
Nivo and I were there...Rick did exactly what he said he did and has the timeslips to prove it! He really knows how to drive...we were all in amazement...1.8x 60' on street tires proves great launching skills! Just glad we were there in support for his big day.

OK SO NOW THERE ARE 5 SRT-4s FROM MASSACHUSETTS IN THE 12'S!!!!!!
 

·
Registered
Joined
·
21 Posts
The reason I was asking about the shift points is because usually .1 seconds quicker in the 60' will lead to .2 seconds quicker in the 1/4. Take run #1 and #3 for example, with a 2.166 60' and a 12.941, I would expect your 2.000 60' to atleast be a 12.7XX. If you look at the incrementals it really looks like the car died off after the 1/8 on run #3.
 

·
Registered
Joined
·
4,074 Posts
Discussion Starter · #19 · (Edited)
RoostBoost said:
Nice job on streets!! How much fuel are you pulling out across the board with those 750's?
about 28-31% all the way across. the reason i have these on the stock turbo is that i tried adding fuel with the stock injectors and i got the high voltage code because of my lack of a map clamp. so i had found a good deal on used 750's and put them on my car, now i dont have to add any fuel im just taking a whole lot of it away so i dont have to worry about the voltage. i think the runs were so inconsistent because i believe that i still have a lil boost leak, it spikes to about 21psi but then falls back to 14-15 and even if i tighten the wastegate it wont keep the boost up. oh and yes this is my first stick car, i got it in sept last year but i also lost my liscense for 6 months so i've been drivin stick for like 7 months. when i raced a month after i got my car, the first time i've EVER raced at the track i got a 14.0 best of the day still stock.
 
1 - 20 of 34 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top