What is limiting timing? - Page 4 - Dodge SRT Forum
 6Likes
Reply
 
LinkBack Thread Tools Display Modes
post #46 of 49 (permalink) Old 06-05-2018, 01:11 PM
SRTforums Member
 
skubasteeve's Avatar
 
Join Date: Jul 2003
Location: Saskatchewan, Canada
Posts: 111
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Im curious to know how this played out, sorry for the resurrection.

05 SRT4
skubasteeve is offline  
Sponsored Links
Advertisement
 
post #47 of 49 (permalink) Old 06-05-2018, 02:14 PM Thread Starter
SRTforums Member
 
Join Date: Nov 2012
Location: SoCal
Posts: 364
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 81 Post(s)
Quote:
Originally Posted by skubasteeve View Post
Im curious to know how this played out, sorry for the resurrection.
Biggest issue was bad iat sensor. More timing didn't help power any though, but I'm having another issue right now with crank case pressure, so that's probably why no power gains.

2005 ACR
Duster360 custom tune, 16G BWS, Fully bored TB, Meth Injection,1025cc injectors, over-sized valves,HKS BOV, AGP WGA, 3 bar map/tip, Thermal R&D 3" TBE, AEM CAI, AEM wideband, MPx catch can, fuel pump rewire, booger shifter bushings, solid engine mounts, energy suspension bushings.

2014 Genesis Coupe 3.8 R-Spec
Has some mods
titan2782 is offline  
post #48 of 49 (permalink) Old 06-08-2018, 02:07 PM
SRTforums Member
 
skubasteeve's Avatar
 
Join Date: Jul 2003
Location: Saskatchewan, Canada
Posts: 111
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
I am getting like 55* advance timing on the Diablo perf tune, I am completely lost with this stuff, and I cant post new threads on this post, I have been a member for a long time but finally just got back into an SRT4. I dont even know who to contact about that. Or even who can look at my log, ill put it here so someone can look if they want. I dont even who still posts.
Attached Files
File Type: zip detko.zip (232.3 KB, 6 views)

05 SRT4
skubasteeve is offline  
 
post #49 of 49 (permalink) Old 06-08-2018, 04:15 PM
Super Moderator
 
RTShadow's Avatar
 
Join Date: Jun 2004
Location: Middle Earth
Posts: 15,564
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Garage
Lifetime Premium Member
Quote:
Originally Posted by titan2782 View Post
Biggest issue was bad iat sensor. More timing didn't help power any though, but I'm having another issue right now with crank case pressure, so that's probably why no power gains.
That freaking IAT sensor can be a problem for a lot of things.

In the 2002 Neon I am working on, battery light and check engine light were on, turned out it was the IAT sensor, apparently it doubles as the battery temperature sensor, giving the computer info it uses to decide what rate the alternator charges the battery at. When it isn't working right, it charges at the full rate, causing the battery and engine light to go off.

Took a bit for me to figure that out, ended up just having to jiggle the stinking sensor around to get it to start working right.

RTShadow is offline  
Sponsored Links
Advertisement
 
Reply

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome