A bunch of questions really - Dodge SRT Forum
 1Likes
  • 1 Post By enginjoe
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 06-17-2019, 08:59 PM Thread Starter
SRTforums Member
 
boostfreak411's Avatar
 
Join Date: May 2008
Location: Virginia Beach
Posts: 264
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
A bunch of questions really

Ok so I’m not new to srts been working on them for years and yes more than one I’ve rebuilt shells to running cars and done swaps but I’ve had some trust issues with a new set up . Example I’ve never used glow shift gauges and don’t know how accurate they actually are. So with that being said I have a oil gauge that’s glow shift and it isn’t reading but I’m at a loss because I don’t remember the oil pressure that the head needs but my oil light came on (which I think is the oil sender again) but I’m going to be looking at that in the morning . I’m also running into a over boost issue and throttle issue as well and I’m trying to get this car tuned by Nigel but seems like one bs problem after another any help would be appreciated
boostfreak411 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 06-18-2019, 06:56 AM
"Made" Member
 
HybridKid's Avatar
 
Join Date: Apr 2003
Location: Heaven
Posts: 6,682
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 1178 Post(s)
Can you provide more detail of the symptoms of the boost and throttle issue, they could be related. In the meantime I would check the vacuum lines and the WG actuator if you are running a stock setup. It could also be a torn or bad diaphragm on the WG. A rundown of your setup would be helpful too.
HybridKid is offline  
post #3 of 7 (permalink) Old 06-19-2019, 08:45 AM Thread Starter
SRTforums Member
 
boostfreak411's Avatar
 
Join Date: May 2008
Location: Virginia Beach
Posts: 264
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
The car has an s256 kit with a precision 39mm wastegate a 62mm throttle body and most of the vacuum lines deleted with a hallman in cabin boost controller the wastegate has a 10lb spring in it and over boosts to about 30 and doesn’t hold primarily cause I let off and that’s at about 4 grand it hits over boost to about 30 even though I have the boost controller turned all the way down and I have checked all vacuum lines that I have which are like 2 of them plus zip tied what vacuum lines I thought may leak by and as far as the idle hanging I think I may have gotten that when I found the intake manifold cracked earlier this morning
boostfreak411 is offline  
 
post #4 of 7 (permalink) Old 06-19-2019, 10:19 AM
SRTforums Member
 
Join Date: Sep 2003
Location: Tucson
Posts: 7,390
Mentioned: 1 Post(s)
Tagged: 1 Thread(s)
Quoted: 413 Post(s)
Glowshift is junk.

Hook your wastegate straight to boost source (basically remove boost controller from circuit) with a leak free vacuum line. If you still overboost, your wastegate is not functioning. If it holds 10psi, there is a leak in your boost control lines or your boost controller is not working correctly.
DarKKnight54 likes this.

2005 SRT-4, 47lb wheel Stage 3, E85...
2002 Camaro SS M6, PTE 7675 Turbo, E85...
2003 SRT-4 Sold!
enginjoe is offline  
post #5 of 7 (permalink) Old 06-19-2019, 01:57 PM
SRTforums Member
 
DarKKnight54's Avatar
 
Join Date: Jun 2013
Location: MO
Posts: 281
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 56 Post(s)
Garage
I agree w Enginejoe, GS gauges are junk. Your pressure will vary whether is placed on the head or block. I think placed on the head it will jump around more
DarKKnight54 is offline  
post #6 of 7 (permalink) Old 06-19-2019, 05:35 PM
SRTforums Member
 
Join Date: Sep 2003
Location: Tucson
Posts: 7,390
Mentioned: 1 Post(s)
Tagged: 1 Thread(s)
Quoted: 413 Post(s)
I had a pressure sensor in the head on my first build. I knew it would read a little lower than in the block, but I did a little research and went with that because it was way easier. At cold start the idle pressure was around 25-30psi and once the car was fully up to temp and run for a while, it was high teens. Cruise was 40 down to high twenties depending on gear and speed. Of course the pressure rose correctly with RPMs.

I used it as a canary in the coal mine that was better than the stock sensor that lights the light when you are at 4 psi. I figured if the pressure changed drastically from what it always read, that would be the time to shut down and do some troubleshooting.

2005 SRT-4, 47lb wheel Stage 3, E85...
2002 Camaro SS M6, PTE 7675 Turbo, E85...
2003 SRT-4 Sold!
enginjoe is offline  
post #7 of 7 (permalink) Old 06-19-2019, 10:54 PM Thread Starter
SRTforums Member
 
boostfreak411's Avatar
 
Join Date: May 2008
Location: Virginia Beach
Posts: 264
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I have read up on gs gauges and come to the same conclusion however it’s not my car I’m just getting as many issues taken care of and trying to tune it. I’m also looking at more possible vacuum lines and yes I’ve by passed the boost controller with the same resolve so I’ve got another tial wastegate in my garage I’m going to swap that out and try with that wastegate as well but just on wastegate spring pressure alone and I’ve been talking to my friend about getting better gauges so I think I’m just going to get them for him so he knows what true quality is. I’ve also ran into an issue with noise at idle but the same noise when I get up to about 2 grand . It’s like a rattle but I’ve already done a compression test and it’s good but I did find one of the ears on the intake cracked so I changed that but didn’t really change anything as far as how it’s running but I’ll swap the wastegates out probably Friday and I’ll let y’all know what comes of it thanks for the help y’all
boostfreak411 is offline  
Sponsored Links
Advertisement
 
Reply

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Official Mopar/DCX Questions - Rules, and Info ekool Site Rules/Updates/Discussion 87 08-17-2004 04:34 PM
Questions and honest opinions. Charonek SRT-4 Discussion 13 05-03-2004 06:03 AM
We need your help! Trivia Questions! ekool Site Rules/Updates/Discussion 15 02-08-2004 11:51 AM
N00b Questions... djphrenzy SRT-4 Discussion 4 01-31-2004 05:55 AM
Questions About The SRT-4 Selcher Canadian 4 10-28-2003 08:00 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome