Power steering leak - Dodge SRT Forum
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 01-04-2019, 03:51 PM Thread Starter
SRTforums Member
 
BrothaGrimm's Avatar
 
Join Date: Nov 2017
Posts: 66
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 11 Post(s)
Garage
Power steering leak

So about a month ago my serpentine belt fell off due to the tensioner breaking. I just now had a chance to replace the tensioner and belt today. I realized my power steering reservoir was empty. I went ahead and replaced the two pieces and filled the reservoir back up. Well when everything was done I started the car. And boom power steering fluid is squirting all over the down pipe, making it to the turbo, and even some is squirting far enough to come through the passenger side wheel. I can’t visibly see where it’s coming from on top. And I havnt had a chance to check down lol. But I did notice my ps cooler is pretty banged up. But another thing is my steering wheel started to shake pretty violently over 60mph. Any ideas? I’ve been looking into just doing the whole steering rack. But if that’s not my problem then no thanks n

04 srt4
Stage 1 Pcm, hks Bov, AGP wastegate, crappy eBay parts.
BrothaGrimm is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 01-04-2019, 09:02 PM
"Made" Member
 
HybridKid's Avatar
 
Join Date: Apr 2003
Location: Heaven
Posts: 6,684
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 1178 Post(s)
Not sure why the shaking but under the downpipe resides all the lines running to and from the cooler, no telling until you get up under there and find the issue.
HybridKid is online now  
post #3 of 8 (permalink) Old 01-05-2019, 01:49 PM Thread Starter
SRTforums Member
 
BrothaGrimm's Avatar
 
Join Date: Nov 2017
Posts: 66
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 11 Post(s)
Garage
I’m going to try to get down and look at it today. I did notice the boot on the inner tie rod looks pulled inwards on the passenger side. I also noticed that one of the busing on the lca is also shot. Not sure if that would cause a vibration that bad.

04 srt4
Stage 1 Pcm, hks Bov, AGP wastegate, crappy eBay parts.
BrothaGrimm is offline  
 
post #4 of 8 (permalink) Old 01-05-2019, 08:01 PM
"Made" Member
 
HybridKid's Avatar
 
Join Date: Apr 2003
Location: Heaven
Posts: 6,684
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 1178 Post(s)
Quote:
Originally Posted by BrothaGrimm View Post
I also noticed that one of the busing on the lca is also shot. Not sure if that would cause a vibration that bad.
Yes, it will.
HybridKid is online now  
post #5 of 8 (permalink) Old 01-07-2019, 06:20 AM
Premium Member (Lifetime)
 
gump1114's Avatar
 
Join Date: May 2005
Location: Byron, GA
Posts: 3,186
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 126 Post(s)
Garage
Lifetime Premium Member
sounds like your car is begging to have some PMs (preventative maintenance) done to it.

Consider the age of these cars and no doubt the mileage and figure anything rubber is likely worn and needs inspecting/replacing. That goes for belts, bushings, and lines.

Personally, if my PS ever acts up, its getting ripped out. I hate how the system is routed and runs under the engine. Ive gone back and forth on whether to just take it out anyways...


435 HP & 438 TQ -E85
Tuned by Turbo666 on his mustang dyno

Best ET to date: 12.1 @ 124 on DR's
gump1114 is offline  
post #6 of 8 (permalink) Old 01-07-2019, 10:05 AM
SRTforums Member
 
Join Date: Jul 2005
Location: Kansas City Are
Posts: 5,576
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 89 Post(s)
^I regretted removing the PS on my old silver SRT-4. Now if it is a drag only car then I say go for it. I think having a manual rack swapped in will help to. Or completely gutting the factory rack and resealing it. (sorry for the hijack OP)

I had my OEM PS pump whining bad. Put in a reman one in and it leaked out the seal on the bottom. Go Mopar OEM if they are available still. Very pricey from what I remember from like 7 or 8 years ago. Having a bad pump will put extra strain on the rack too. which ended up failing on mine too. First reman rack was bad, was missing a port. 2nd one was a winner. Ended up looping the lines on it and removing the PS. Regretted doing that. PITA to drive in parking lots or low speed.

05 PW1 SRT-4
AGP 50 trim and supporting mods
s3*ps2 is offline  
post #7 of 8 (permalink) Old 01-07-2019, 10:23 AM
Premium Member (Lifetime)
 
gump1114's Avatar
 
Join Date: May 2005
Location: Byron, GA
Posts: 3,186
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 126 Post(s)
Garage
Lifetime Premium Member
Quote:
Originally Posted by s3*ps2 View Post
completely gutting the factory rack and resealing it.
this is what i would do if i did remove PS. There are how-tos and youtube videos out there showing how to do it to the SRT rack.

BUT, since i've never had an issue with mine... it hasnt pissed me off enough to remove it.


435 HP & 438 TQ -E85
Tuned by Turbo666 on his mustang dyno

Best ET to date: 12.1 @ 124 on DR's
gump1114 is offline  
post #8 of 8 (permalink) Old 01-08-2019, 08:42 AM Thread Starter
SRTforums Member
 
BrothaGrimm's Avatar
 
Join Date: Nov 2017
Posts: 66
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 11 Post(s)
Garage
I seen a video on how to de-power the rack. But I havnt considered it yet. I took the passenger wheel off looking for what the problem is. But it looks like the inner tie rod is just leaking fluid out of it.

04 srt4
Stage 1 Pcm, hks Bov, AGP wastegate, crappy eBay parts.
BrothaGrimm is offline  
Sponsored Links
Advertisement
 
Reply

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome