Low compression numbers? - Dodge SRT Forum
 5Likes
  • 1 Post By s3*ps2
  • 2 Post By lVlemphizStylez
  • 2 Post By Simon.Starkie
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 04-14-2019, 06:32 PM Thread Starter
SRTforums Member
 
mmasire88's Avatar
 
Join Date: Jul 2018
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Garage
Low compression numbers?

Hey fellas, just looking for some of your thoughts on this. I've been struggling with low boost on this srt-4 since I first bought it a year ago. It runs and drives great, but it does struggle to make much power. No check engine lights to speak of. I started running out of ideas and yanked the wastegate vacuum line off and it makes 3-4 psi less without mbc on it. Even with the MBC it spikes around 13-14psi and falls down to around 8-9psi.

I hadn't considered the engine may be worn out, just because it does run really well. I pulled the intake manifold off and fuel rail, replaced all the injector O-rings, intake manifold gasket with no changes. I ran a compression test on all 4 cylinders and they all hit 130psi ON the dot. Add a couple drops of oil, retest and it shoots up to about 140-145psi on each cylinder. I guess one of my main questions here is whether worn rings are going to affect the performance of the turbo like that?

I've been over most of the vacuum lines and I just can't find anything else. It has an AGP wastegate that I've ran several different springs in and replaced the rubber diaphram. I'm assuming I'm going to be doing an engine rebuild this next week? ;(

mmasire88 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 04-14-2019, 08:43 PM
SRTforums Member
 
Join Date: Jul 2005
Location: Kansas City Are
Posts: 5,544
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 77 Post(s)
LOL. Sorry but I have to laugh. I had 120 in all 4 cylinders @ 34 degrees farenheit. And I made 380whp/382wtq on 93 octane with a 50 trim setup. Your compression is fine and you don't have to rebuild your motor. Unless your car is burning a ton of oil. Whcih you never said it was. FSM says atleast 100psi in all 4 cylinders. Compression gauges run differently. You just want to make sure all the numbers are the same. Or very close.

What turbo are you running? If you are running a stock turbo you would be a fool to take it off of PCM controlled boost. I had best luck with the STOCK wga on a stock turbo car. Get a custom diablo email tune and you will be fine.

Do a boost leak check since you have not mentioned doing one yet.
HybridKid likes this.

05 PW1 SRT-4
AGP 50 trim and supporting mods
s3*ps2 is offline  
post #3 of 7 (permalink) Old 04-14-2019, 09:09 PM Thread Starter
SRTforums Member
 
mmasire88's Avatar
 
Join Date: Jul 2018
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Garage
Oh yea, I jumped the gun and assumed that would be the case. It burns a TON of oil. lol When I start it up in the garage, it sprays black soot all over my garage door. Tempted to go take a picture because it's absolutely ridiculous. It's mostly all stock engine wise, has a few little things like CAI, it has I believe a 3'' downpipe to 3'' midsection and I think the back foot or so looks a bit smaller. Stock PCM, stock turbo, so nothing major. I pulled off and cleaned/inspected all the intercooler piping and installed the new UTP charge pipe. I had the turbo off last summer, fixing 3 broken surge valve bolts and it was clean, no shaft play (in or out).

My reasoning for taking it off pcm controlled boost is just temporary. It seemed like the best way to simplify and make troubleshooting a bit easier, as well as attempt to manipulate it manually, which it seems to have a mind of it's own. It will be going back on pcm controlled boost once I get this figured out. I'm not at all opposed to rebuilding the block, but the timing is always convenient. Spring is here, time for the toys to start breaking.


Last edited by mmasire88; 04-14-2019 at 09:21 PM.
mmasire88 is offline  
 
post #4 of 7 (permalink) Old 04-14-2019, 09:38 PM Thread Starter
SRTforums Member
 
mmasire88's Avatar
 
Join Date: Jul 2018
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Garage
I have a super old diablosport predator tuner I had used on my 03’ srt4. Gonna have to remember where that is...

Lovely exhaust soot on garage door as promised.
Attached Thumbnails
Click image for larger version

Name:	20DD53D3-12EF-4560-8A46-EB13E8753826_1555299357346.jpg
Views:	10
Size:	245.8 KB
ID:	138177  

mmasire88 is offline  
post #5 of 7 (permalink) Old 04-15-2019, 06:18 AM
SRTforums Member
 
Join Date: Feb 2007
Location: POS Michigan
Posts: 5,897
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 144 Post(s)
Garage
pull it out if it's burning oil.....

If the valve seals and turbo aren't culprit then the engine needs an overhaul. Compression and leakdown numbers don't tell the whole story. Compression and leakdown tests don't qualify the oil control rings which can lose tension and stick.



This engine had PERFECT leakdown and compression.....put down great power numbers. It burned oil like a champion. Short of tearing it apart...not much could have been done to diagnose the problem (I knew it had to come out just didnt know what I'd find); sometimes it's like that
HybridKid and mmasire88 like this.

go ahead...change yours too now; again

Last edited by lVlemphizStylez; 04-15-2019 at 06:27 AM.
lVlemphizStylez is offline  
post #6 of 7 (permalink) Old 04-15-2019, 02:35 PM Thread Starter
SRTforums Member
 
mmasire88's Avatar
 
Join Date: Jul 2018
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Garage
I had the intake manifold off and it had enough oil in intake runners I could scrape it off with my finger and probably use it as some kind of grease -_-. All the way into the head and in the valves.. I've put around 2,000 miles on in this past year and I just had to put 1.5 quarts of oil in it last weekend. Probably just clean the head really well, I don't know if I want to get into rebuilding the head. Literally just finished my Volvo and I'm not keen on grinding more valves by hand. We'll pull it out on Friday drop the bottom end off at the machine shop. Thanks for the info and carnage pics, it's always fun to see.

mmasire88 is offline  
post #7 of 7 (permalink) Old 04-15-2019, 03:01 PM
SRTforums Member
 
Join Date: Jun 2003
Posts: 3,747
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 270 Post(s)
If it were me, I'd first want to check some know problem areas with these cars.

You might want to try a new PCV valve.
Modern Performance sells them for less than $10.

You might also want to remove and clean the turbo oil drain pipe.
If it's blocked with the gunk you found on the IM then that could also cause a smokey oil burner.

You might also want to drain and clean out the FMIC and IM as well.

When those steps are done, you might want to install a catch can to try and prevent oily blow-by from contaminating the intake track you just cleaned.

You should avoid check valves for now as they can cause more troubles than you already have.
HybridKid and mmasire88 like this.
Simon.Starkie is offline  
Sponsored Links
Advertisement
 
Reply

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Trouble Code List OWN3D SRT Problems & Dealer Service 201 03-29-2016 07:01 AM
p0234, pissing me off, clarify for me please. UN-decided SRT-4 Discussion 12 07-14-2004 08:29 PM
i really hate this car, P0301? solarCTsrt4 SRT Problems & Dealer Service 26 05-12-2004 03:54 PM
Error code! P 0129 2003_Red_Srt-4 SRT Problems & Dealer Service 3 01-24-2004 08:18 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome