What Have You Done To Your Srt4 Lately? - Page 1430 - Dodge SRT Forum
 2163Likes
 
LinkBack Thread Tools Display Modes
post #21436 of 21482 (permalink) Old 06-20-2019, 06:07 AM
SRTforums Member
 
T4EaterJonny's Avatar
 
Join Date: May 2007
Location: Corona, CA
Posts: 2,811
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 435 Post(s)
Garage
Quote:
Originally Posted by gump1114 View Post
ah good catch... you're right. intex makes those shitting kids pools.... lol
Lmao WHAT?!What fuel pump are you going to go with?

Red 2005 Big wheel stage 3, E85, BC rods, JE pistons stock 8:1 .020 over, BS delete, Sways & STbraces, coilovers valved by Feal, diy NACHO solid control arms.
Yellow 2004 C5Z06
White1994 XR600R street legal! Have you driven an SRT-4?... Lately?
T4EaterJonny is offline  
Sponsored Links
Advertisement
 
post #21437 of 21482 (permalink) Old 06-20-2019, 06:18 AM
Premium Member (Lifetime)
 
gump1114's Avatar
 
Join Date: May 2005
Location: Byron, GA
Posts: 3,186
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 126 Post(s)
Garage
Lifetime Premium Member
Quote:
Originally Posted by T4EaterJonny View Post
Lmao WHAT?!What fuel pump are you going to go with?
honestly, i ordered a cheap oem replacement off of amazon. *fingers crossed* this car has been down for over 3 years and i need to get it moving again. I'm confident this will work for the time being.

keep in mind that the in-tank pump on my car does not feed the engine (surge tank setup), my Bosch 044 pump does, so there is very little strain on this pump. Also, for the time being, i'm just going to run the car on 93oct fuel so i'm not too concerned with e85 compatibility.


435 HP & 438 TQ -E85
Tuned by Turbo666 on his mustang dyno

Best ET to date: 12.1 @ 124 on DR's
gump1114 is offline  
post #21438 of 21482 (permalink) Old 06-20-2019, 08:19 AM
Premium Member (Lifetime)
 
dave gregory's Avatar
 
Join Date: Mar 2005
Location: Hutchinson, MN
Posts: 1,361
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 13 Post(s)
Lifetime Premium Member
During that down time (3 years) was E85 in the tank?

Thanks!!!

1986 GLHS #329
2004 SRT4 Powered by DCR & Forward Motion
FM Stock Appearing Stage 5 Buildup (E1 Turbo, Factory cams/gears) Turn Key Ready
dave gregory is offline  
 
post #21439 of 21482 (permalink) Old 06-20-2019, 08:22 AM
Premium Member (Lifetime)
 
gump1114's Avatar
 
Join Date: May 2005
Location: Byron, GA
Posts: 3,186
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 126 Post(s)
Garage
Lifetime Premium Member
Quote:
Originally Posted by dave gregory View Post
During that down time (3 years) was E85 in the tank?

Thanks!!!
nope. normal 93 oct.


435 HP & 438 TQ -E85
Tuned by Turbo666 on his mustang dyno

Best ET to date: 12.1 @ 124 on DR's
gump1114 is offline  
post #21440 of 21482 (permalink) Old 06-20-2019, 05:46 PM
Premium Member (Lifetime)
 
dave gregory's Avatar
 
Join Date: Mar 2005
Location: Hutchinson, MN
Posts: 1,361
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 13 Post(s)
Lifetime Premium Member
Got it, thanks!!!

1986 GLHS #329
2004 SRT4 Powered by DCR & Forward Motion
FM Stock Appearing Stage 5 Buildup (E1 Turbo, Factory cams/gears) Turn Key Ready
dave gregory is offline  
post #21441 of 21482 (permalink) Old 06-20-2019, 09:45 PM
SRTforums Member
 
T4EaterJonny's Avatar
 
Join Date: May 2007
Location: Corona, CA
Posts: 2,811
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 435 Post(s)
Garage
My level sensor went all wacky with e85. Haven’t ran real gas in it in a long time. Now it works again. Needle at the full mark when tank is full. Weird.

Red 2005 Big wheel stage 3, E85, BC rods, JE pistons stock 8:1 .020 over, BS delete, Sways & STbraces, coilovers valved by Feal, diy NACHO solid control arms.
Yellow 2004 C5Z06
White1994 XR600R street legal! Have you driven an SRT-4?... Lately?
T4EaterJonny is offline  
post #21442 of 21482 (permalink) Old 06-21-2019, 04:32 AM
Premium Member (Lifetime)
 
gump1114's Avatar
 
Join Date: May 2005
Location: Byron, GA
Posts: 3,186
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 126 Post(s)
Garage
Lifetime Premium Member
I threw the pump assembly in last night and got the tank put back up under there. The pump works and the gauge seems to be reading right. A couple of the o-rings on some of my AN fittings broke when i took them off and i didnt have any replacements at home. I'll get some today and should be able to start the car up this evening with fresh gas. I also installed my new K&N filter (i run a filter straight on the turbo).

All thats left now is to replace the axle seal that is leaking and i should be good to go.

I want to polish up the intercooler too, but i'm dreading it... lol


435 HP & 438 TQ -E85
Tuned by Turbo666 on his mustang dyno

Best ET to date: 12.1 @ 124 on DR's
gump1114 is offline  
post #21443 of 21482 (permalink) Old 06-23-2019, 07:21 AM
SRTforums Member
 
bzzt's Avatar
 
Join Date: Mar 2011
Location: Chicago Suburbs
Posts: 6,358
Mentioned: 17 Post(s)
Tagged: 1 Thread(s)
Quoted: 1949 Post(s)
Upper radiator hose sprung a leak.
The one I got from AutoZone doesn't have the extra little bend at the passenger side end but seems ok.



2004 Silver SRT-4
Stage I, AEM CAI, UDP, cut balance chain
bzzt is offline  
post #21444 of 21482 (permalink) Old 06-23-2019, 05:57 PM
New Member
 
Labar Alexander's Avatar
 
Join Date: Jun 2019
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I looked at it, looking at me while parked in the driveway. Crosshairs are making a ☹️. Bad piston rings. Forged time.
Labar Alexander is offline  
post #21445 of 21482 (permalink) Old 06-23-2019, 08:30 PM
Premium Member (Lifetime)
 
gump1114's Avatar
 
Join Date: May 2005
Location: Byron, GA
Posts: 3,186
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 126 Post(s)
Garage
Lifetime Premium Member
Still havenít replaced the axle seal, but I got her together enough to get her out to a local car meet. She hasnít had a bath in over 3 years, but she didnít look half bad. Bumper still not on because I want to polish the intercooler.
Attached Thumbnails
Click image for larger version

Name:	8D913098-0BFF-46A1-AA80-E088079849D6.jpg
Views:	8
Size:	505.3 KB
ID:	138275  


435 HP & 438 TQ -E85
Tuned by Turbo666 on his mustang dyno

Best ET to date: 12.1 @ 124 on DR's
gump1114 is offline  
post #21446 of 21482 (permalink) Old 06-24-2019, 02:42 AM
SRTforums Member
 
Join Date: Feb 2007
Location: POS Michigan
Posts: 5,918
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 155 Post(s)
Garage

Little speedo action yesterday. We've been having beautiful weather lately which is rare for the Midwest. It's a great feeling when your car is running 100% and you know it's all by your hand. Local shop (criminal) took me for a ride and ruined my previous motor when I outsourced some work due to time and space constraints so I had to redo the WHOLE CAR over last winter in my garage.

I'm still impressed with how well this setup breathes to perform like it does on low octane fuel. Tubular manifold and a good cylinder head really change the way these cars make power. It's like a Honda with torque now....instead of a 4 cylinder diesel engine lmao
HybridKid and bzzt like this.

go ahead...change yours too now; again

Last edited by lVlemphizStylez; 06-24-2019 at 03:08 AM.
lVlemphizStylez is offline  
post #21447 of 21482 (permalink) Old 06-24-2019, 02:47 AM
SRTforums Member
 
Join Date: Feb 2007
Location: POS Michigan
Posts: 5,918
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 155 Post(s)
Garage
Quote:
Originally Posted by gump1114 View Post
Still havenít replaced the axle seal, but I got her together enough to get her out to a local car meet. She hasnít had a bath in over 3 years, but she didnít look half bad. Bumper still not on because I want to polish the intercooler.
car looks mean man

go ahead...change yours too now; again
lVlemphizStylez is offline  
post #21448 of 21482 (permalink) Old 06-24-2019, 09:26 AM
SRTforums Member
 
JeremyJ's Avatar
 
Join Date: Jun 2004
Location: Washington
Posts: 701
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 13 Post(s)
Quote:
Originally Posted by gump1114 View Post
Still havenít replaced the axle seal, but I got her together enough to get her out to a local car meet. She hasnít had a bath in over 3 years, but she didnít look half bad. Bumper still not on because I want to polish the intercooler.
Oh man. This whole time I thought your sig pic was a glowing brake rotor. The orange rim makes so much more sense.

02 Base - 05 SRT ACR - 96 Sedan - 99 R/T - 02 R/T - 03 SRT
JeremyJ is offline  
post #21449 of 21482 (permalink) Old 06-24-2019, 09:39 AM
Premium Member (Lifetime)
 
gump1114's Avatar
 
Join Date: May 2005
Location: Byron, GA
Posts: 3,186
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 126 Post(s)
Garage
Lifetime Premium Member
Quote:
Originally Posted by JeremyJ View Post
Oh man. This whole time I thought your sig pic was a glowing brake rotor. The orange rim makes so much more sense.
haha... that would be kinda neat to see... except that picture in my sig is on a drag strip. The orange/black wheels are my steelies for my drag radials.


435 HP & 438 TQ -E85
Tuned by Turbo666 on his mustang dyno

Best ET to date: 12.1 @ 124 on DR's
gump1114 is offline  
post #21450 of 21482 (permalink) Old 06-24-2019, 11:24 AM
SRTforums Member
 
JeremyJ's Avatar
 
Join Date: Jun 2004
Location: Washington
Posts: 701
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 13 Post(s)
Last night I think I blew the coolant return line behind the turbo. Anyone else ever replaced this line before? It seems impossible to get to. I can find a couple of horror stories about it from searching, but no real how-to.

02 Base - 05 SRT ACR - 96 Sedan - 99 R/T - 02 R/T - 03 SRT
JeremyJ is offline  
Sponsored Links
Advertisement
 
Reply

User Tag List
turbo666

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome