How-To: Properly Wire HID Bi-Xenon Harness - Page 2 - Dodge SRT Forum
LinkBack Thread Tools Display Modes
post #16 of 18 (permalink) Old 01-02-2013, 11:46 PM
SRTforums Member
srt4diablo's Avatar
Join Date: Oct 2007
Location: bakersfield ca
Posts: 124
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Zombie!!!! Back from the dead, just installed some h.I.D's on my buddys car and everything worked .... but once I slapped on the bumper on and tried it again and the passenger keeps blowing low rt beam fuse
I installed the stock light bulb and the fuse doesn't blow, so I was cleaning up and notice that the wires coming from the ballast was wet.. I'm hoping thats the problem and just gonna let it dry up over night. Oh BTW with the hids high beams wouldn't blow fuse. I'll update tomorrow if anyone even reads this haha.

2005 SRT4
13.3 on 93 tune and street non brand tires and race fuel...

srt4diablo is offline  
Sponsored Links
post #17 of 18 (permalink) Old 01-03-2013, 11:49 AM
SRTforums Member
all blacked out's Avatar
Join Date: Mar 2011
Location: northern ky
Posts: 248
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Ok so I have a bi-xenon kit it says it the 9004 kit. So all I have to do is switch the white and brown wire and run that diode from the blue to the new location of the white wire? My wires now from left to right are brown white blue. It should be white brown blue correct?

Last edited by all blacked out; 01-03-2013 at 11:53 AM.
all blacked out is online now  
post #18 of 18 (permalink) Old 01-04-2013, 01:09 AM Thread Starter
SRTforums Member
Legoman's Avatar
Join Date: May 2007
Location: Berlin Germany
Posts: 3,242
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Legoman is offline  
Sponsored Links

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome