Driver's power window problem - SRT Forums - SRT4, SRT6, SRT8, SRT10 & Dodge Forum
 
 


Go Back   SRT Forums - SRT4, SRT6, SRT8, SRT10 & Dodge Forum > Regional Forums > US Regional Forums > Northwest

SrtForums.com is the premier Dodge SRT Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 12-27-2010, 08:23 PM   #1 (permalink)
SRTforums Member
 
R(k)'s Avatar
 
Join Date: Aug 2010
Member Number: 80585
Location: Kitsap Co, WA
Posts: 23
Default Driver's power window problem

My driver's side power window recently became very slow and eventually stopped working altogether. My passenger window is as fast as it's ever been.

I replaced the window motor but no dice- still won't budge. I felt around in there for anything that could be binding but the track feels clear. The motor turns freely when not attached to the other half in the door.

I don't know how to diagnose that other part, I've never encountered a cable unit like that.

Ideas?
R(k) is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-27-2010, 08:37 PM   #2 (permalink)
SRTforums Member
 
DreSRT's Avatar
 
Join Date: May 2007
Member Number: 54384
Location: IN MY NEON
Posts: 1,291
Default

i had the same problem and all i did was take the switch apart and sanded the little metal ends and it has been working ever since.
__________________
Dear honda Owner, your vtec is not a turbo.
DreSRT is offline   Reply With Quote
Old 12-27-2010, 09:07 PM   #3 (permalink)
SRTforums Member
 
Join Date: Oct 2004
Member Number: 19673
Location: Gresham, OR
Posts: 1,896
Default

Quote: Originally Posted by DreSRT View Post
i had the same problem and all i did was take the switch apart and sanded the little metal ends and it has been working ever since.

yup, corrosion on the switch can really kill it
__________________
Project: Heavyweapon
"Wrong wheel drive for all the right reasons."

PTE6266: 10.65 best et | 139mph best trap | 1.62 best 60'
Let the quest for single digits begin!

Find more pictures and info:
Build Thread | Facebook | Instagram
Checksum is offline   Reply With Quote
Old 12-27-2010, 09:30 PM   #4 (permalink)
SRTforums Member
 
R(k)'s Avatar
 
Join Date: Aug 2010
Member Number: 80585
Location: Kitsap Co, WA
Posts: 23
Default

Cool, thanks. I'll check the switch contacts tomorrow.
R(k) is offline   Reply With Quote
Old 12-27-2010, 09:53 PM   #5 (permalink)
SRTforums Member
 
jaymzx's Avatar
 
Join Date: Feb 2003
Member Number: 278
Location: Seattle, WA
Posts: 13,864
Default

Is the regulator binding or anything?
__________________
James
Team Positive Intake Manifold Pressure (PIMP)
READ AND LEARN:
Engines Transmissions Turbochargers Horsepower Torque
jaymzx is offline   Reply With Quote
Old 12-27-2010, 10:00 PM   #6 (permalink)
SRTforums Member
 
R(k)'s Avatar
 
Join Date: Aug 2010
Member Number: 80585
Location: Kitsap Co, WA
Posts: 23
Default

Quote: Originally Posted by jaymzx View Post
Is the regulator binding or anything?

Not that I can tell, but I've never seen a regulator like this so I'm a little unsure. I've run my hand up and down the guide rail and the center lift and I don't feel any obstructions or anything really that would be in the way.

I have to think if it was something binding that it would have simply seized instead of slowly becoming inoperable, but I could be wrong.
R(k) is offline   Reply With Quote
Old 01-03-2011, 01:25 AM   #7 (permalink)
SRTforums Member
 
DreSRT's Avatar
 
Join Date: May 2007
Member Number: 54384
Location: IN MY NEON
Posts: 1,291
Default

Quote: Originally Posted by R(k) View Post
Not that I can tell, but I've never seen a regulator like this so I'm a little unsure. I've run my hand up and down the guide rail and the center lift and I don't feel any obstructions or anything really that would be in the way.

I have to think if it was something binding that it would have simply seized instead of slowly becoming inoperable, but I could be wrong.

did you ever get this fixed?
__________________
Dear honda Owner, your vtec is not a turbo.
DreSRT is offline   Reply With Quote
Old 01-03-2011, 10:17 PM   #8 (permalink)
SRTforums Member
 
R(k)'s Avatar
 
Join Date: Aug 2010
Member Number: 80585
Location: Kitsap Co, WA
Posts: 23
Default

Quote: Originally Posted by DreSRT View Post
did you ever get this fixed?

Nope, I went out and pulled the switch panel and cleaned all the switch contacts even though they were pretty bright. Still the same deal.

If I get time this week I am going to pull the door panel back off and see if I can figure out where it might be binding or caught.

I was thinking maybe there was a relay as well, but it doesn't seem normal for a relay to fail in this fashion (slow, slower, dead).
R(k) is offline   Reply With Quote
Old 01-04-2011, 07:01 PM   #9 (permalink)
"Made" Member
 
inzanesrt4's Avatar
 
Join Date: Jun 2003
Member Number: 1426
Location: Kent, WA
Posts: 6,667
Lifetime Premium Member
Default

Both Windows should be on the same power window relay.
inzanesrt4 is offline   Reply With Quote
Old 01-04-2011, 10:27 PM   #10 (permalink)
SRTforums Member
 
R(k)'s Avatar
 
Join Date: Aug 2010
Member Number: 80585
Location: Kitsap Co, WA
Posts: 23
Default

Quote: Originally Posted by inzanesrt4 View Post
Both Windows should be on the same power window relay.

Passenger side performs great. Guess I can rule out the relay if they use the same one.
R(k) is offline   Reply With Quote
Old 01-09-2011, 04:57 AM   #11 (permalink)
SRTforums Member
 
Space's Avatar
 
Join Date: Aug 2005
Member Number: 32199
Location: Kent Wa
Posts: 326
Default

Did you grease the shit out of it? Mine's the same. In fact I quit using my drivers side since the cold weather started months ago. The warmer it is, the better it seems to work. I thought maybe the motor was dying since I use it all the time. Perhaps the grease is wore out/broke down, and with the colder weather, it might be thickening up. I don't know, hopefully you can figure yours out so I'll know what to do to mine. Mine will go down, but hell if I'll trust it to go back up, so I leave it up.
Space is offline   Reply With Quote
Old 01-09-2011, 11:54 AM   #12 (permalink)
SRTforums Member
 
jaymzx's Avatar
 
Join Date: Feb 2003
Member Number: 278
Location: Seattle, WA
Posts: 13,864
Default

Beats a stuck sunroof

__________________
James
Team Positive Intake Manifold Pressure (PIMP)
READ AND LEARN:
Engines Transmissions Turbochargers Horsepower Torque
jaymzx is offline   Reply With Quote
Old 01-13-2011, 12:28 PM   #13 (permalink)
SRTforums Member
 
DreSRT's Avatar
 
Join Date: May 2007
Member Number: 54384
Location: IN MY NEON
Posts: 1,291
Default

Quote: Originally Posted by jaymzx View Post
Beats a stuck sunroof


damn sux to be whoever owned that cat.
__________________
Dear honda Owner, your vtec is not a turbo.
DreSRT is offline   Reply With Quote
Old 01-13-2011, 09:48 PM   #14 (permalink)
SRTforums Member
 
Hi N Mity's Avatar
 
Join Date: Aug 2005
Member Number: 33036
Location: WA
Posts: 7,223
Default

our old accord had the same problem. we had to pull up on the window to get it started when we wanted to close it. We replaced the whole window switch and it fixed the problem. the problem is under the switch levers/toggles, not where the harness connects to the assembly. head to a junk yard and find a switch assembly. Normally they pull those kind of parts before putting them in the yard, but its wortha shot
Hi N Mity is offline   Reply With Quote
Old 01-13-2011, 09:52 PM   #15 (permalink)
SRTforums Member
 
Hi N Mity's Avatar
 
Join Date: Aug 2005
Member Number: 33036
Location: WA
Posts: 7,223
Default

00 05 DODGE NEON MASTER DOOR WINDOW SWITCH - eBay (item 170588873766 end time Jan-16-11 11:29:53 PST)
Hi N Mity is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 07:57 AM.



(C) SRTforums.com

Search Engine Friendly URLs by vBSEO 3.3.2