what are syptoms of bad map sensor? - Dodge SRT Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 21 (permalink) Old 03-08-2011, 10:27 AM Thread Starter
SRTforums Member
 
Join Date: Sep 2010
Location: ohio
Posts: 120
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
what are syptoms of bad map sensor?

what are some syptoms of a bad map sensor.. everyones telling me to replace it but no one can tell me what the causes of a bad map sensor will do

2003 Solar Yellow SRT-4
grocery getter.
Bubbaryan17 is offline  
Sponsored Links
Advertisement
 
post #2 of 21 (permalink) Old 03-08-2011, 10:58 AM
SRTforums Member
 
StockTurboJamson's Avatar
 
Join Date: Mar 2009
Location: Phoenixville PA
Posts: 187
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
surging, bucking, rough idle, bad gas mileage, rich condition, detonation, sputtering. all that fun stuff could be associated with a bad map sensor. do you have access to a good scan tool to see what the map sensors saying?

276hp, 373 lb.ft. stock turbo (mustang dyno)
StockTurboJamson is offline  
post #3 of 21 (permalink) Old 03-08-2011, 11:24 AM Thread Starter
SRTforums Member
 
Join Date: Sep 2010
Location: ohio
Posts: 120
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by StockTurboJamson View Post
surging, bucking, rough idle, bad gas mileage, rich condition, detonation, sputtering. all that fun stuff could be associated with a bad map sensor. do you have access to a good scan tool to see what the map sensors saying?
I have a diablo idk if that can read it or not

2003 Solar Yellow SRT-4
grocery getter.
Bubbaryan17 is offline  
post #4 of 21 (permalink) Old 03-08-2011, 07:41 PM
SRTforums Member
 
StockTurboJamson's Avatar
 
Join Date: Mar 2009
Location: Phoenixville PA
Posts: 187
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
whats the car doing?

276hp, 373 lb.ft. stock turbo (mustang dyno)
StockTurboJamson is offline  
post #5 of 21 (permalink) Old 03-09-2011, 09:05 AM Thread Starter
SRTforums Member
 
Join Date: Sep 2010
Location: ohio
Posts: 120
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by StockTurboJamson View Post
whats the car doing?
my air fuel gauge is all over the map.. did a compression test and all 4 r great.. checked turbo, its great, when your driving it its fine. but however if u come to a stop or let it idle for about 15, seconds or more oil smoke starts comming out the exhaust.

2003 Solar Yellow SRT-4
grocery getter.
Bubbaryan17 is offline  
post #6 of 21 (permalink) Old 03-09-2011, 09:06 AM Thread Starter
SRTforums Member
 
Join Date: Sep 2010
Location: ohio
Posts: 120
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
oh and rough idle messed with the tps sensor and nothing changed

2003 Solar Yellow SRT-4
grocery getter.
Bubbaryan17 is offline  
post #7 of 21 (permalink) Old 03-09-2011, 09:18 AM
SRTforums Member
 
KBzPTGT's Avatar
 
Join Date: Dec 2002
Location: Hagerstown
Posts: 1,028
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
how is oil smoke associated with a bad MAP sensor?

Swap your sensor with a known good one
KBzPTGT is offline  
post #8 of 21 (permalink) Old 03-09-2011, 09:39 AM Thread Starter
SRTforums Member
 
Join Date: Sep 2010
Location: ohio
Posts: 120
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Smile

Quote:
Originally Posted by KBzPTGT View Post
how is oil smoke associated with a bad MAP sensor?

Swap your sensor with a known good one
i have the three bar map with the diablo but havent put it on yet

2003 Solar Yellow SRT-4
grocery getter.
Bubbaryan17 is offline  
post #9 of 21 (permalink) Old 03-09-2011, 07:06 PM
SRTforums Member
 
srt4srsexy's Avatar
 
Join Date: Jan 2006
Location: mesa az
Posts: 762
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
what kind of a/f you got? bad map can cause bad a/f ratios cause the car to be lean/rich retard timing or advance.map sends signal to pcm to add fuel and timing or vice versa depending on engine load. do you have a three bar in there now and are you big turbo if you are yes you should have three bar in.

Last edited by srt4srsexy; 03-09-2011 at 07:09 PM.
srt4srsexy is offline  
post #10 of 21 (permalink) Old 03-10-2011, 09:38 AM
SRTforums Member
 
XxWicked_MagixX's Avatar
 
Join Date: Feb 2006
Location: Raleigh, NC
Posts: 1,198
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
sounds like your building crankcase pressure, if your sure the turbo is good and oil smoke is coming out, check your pcv valve and line. if those are good, check your drain line on the turbo
XxWicked_MagixX is offline  
post #11 of 21 (permalink) Old 03-10-2011, 09:41 AM
SRTforums Member
 
Join Date: Apr 2010
Location: South Florida
Posts: 52
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Plug a scanner to the car check the pids and look at the map sensor and tps they should be pretty close together. If the map is reading like really high or 5volts then your shorted. You have to check all your wiring. Your sensor may not be bad it's probably the wiring or connection.
Kayyyle is offline  
post #12 of 21 (permalink) Old 06-23-2011, 01:55 PM
SRTforums Member
 
orangeneon21's Avatar
 
Join Date: Apr 2009
Location: Needville, TX
Posts: 105
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
My engine code throws 2074 and my prob. Is similar to all this.

Last edited by orangeneon21; 06-23-2011 at 01:57 PM. Reason: But no smoke but I am having a whit sling sound
orangeneon21 is offline  
post #13 of 21 (permalink) Old 07-14-2011, 05:33 PM
SRTforums Member
 
DrmCtchr's Avatar
 
Join Date: Feb 2006
Location: Puget Sound
Posts: 1,437
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by Bubbaryan17 View Post
my air fuel gauge is all over the map.. did a compression test and all 4 r great.. checked turbo, its great, when your driving it its fine. but however if u come to a stop or let it idle for about 15, seconds or more oil smoke starts comming out the exhaust.
multiple problems .. the smoke is valve stem seals, likely. the AFRs are probably a bad map or more likely a fouled O2 sensor(s) from the oil leaking into the combustion chamber.
DrmCtchr is offline  
post #14 of 21 (permalink) Old 07-14-2011, 06:19 PM
SRTforums Member
 
_Nick_'s Avatar
 
Join Date: Mar 2004
Location: Camarillo, CA
Posts: 7,124
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
A bad 02 housing gasket can throw off AFR's as well, but they would be lean.

20G Stage 3 on E85: New data:384 hp 411 tq

"Maybe I should just stick to bolt-ons." -Hitler

I don't really want to wrench anymore. I'd rather detail.
_Nick_ is offline  
post #15 of 21 (permalink) Old 10-31-2011, 05:46 PM
SRTforums Member
 
ryeinbee's Avatar
 
Join Date: Oct 2011
Location: Canada
Posts: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Hey guys, need some help.

My cars bogging right out at around 2300 rpms and seems like its gonna die until you let it go back down past 2300... the CEL code is coming up as 'camshaft sensor'. i changed that and no luck. changed plugs, wires and ignition coil and still no luck. ordering a new cat converter.. do you think it could be the MAP sensor??

please get back to me asap

Ryan
ryeinbee is offline  
Sponsored Links
Advertisement
 
Reply

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome