Symptoms of a bad wastegate? - SRT Forums - SRT4, SRT6, SRT8, SRT10 & Dodge Forum
 
 


Go Back   SRT Forums - SRT4, SRT6, SRT8, SRT10 & Dodge Forum > SRT-4 Other Discussion > SRT Problems & Dealer Service

SrtForums.com is the premier Dodge SRT Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 07-26-2010, 06:30 AM   #1 (permalink)
SRTforums Member
 
Join Date: Jun 2008
Member Number: 64835
Location: TN
Posts: 1,760
Default Symptoms of a bad wastegate?

Just wondering what the symptoms of a bad wastegate are, I think mine is going out. With my boost controller turned all the way off, I go WOT and spike 18 psi then it's almost like I'm feathering the gas...goes from 18 to about 5 then back up to 18 then settles at 13 which is the base pressure on the wastegate spring. Any ideas what this could be? I'm going to completely unhook the boost controller and run the wastegate to the compressor housing and see if that fixes it. Anyone know where I can buy a tial rebuild kit for my wastegate?
solarsrt4tn is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-26-2010, 04:55 PM   #2 (permalink)
SRTforums Member
 
Join Date: Feb 2007
Member Number: 51111
Location: POS Michigan
Posts: 5,376
Default

Quote: Originally Posted by solarsrt4tn View Post
Just wondering what the symptoms of a bad wastegate are, I think mine is going out. With my boost controller turned all the way off, I go WOT and spike 18 psi then it's almost like I'm feathering the gas...goes from 18 to about 5 then back up to 18 then settles at 13 which is the base pressure on the wastegate spring. Any ideas what this could be? I'm going to completely unhook the boost controller and run the wastegate to the compressor housing and see if that fixes it. Anyone know where I can buy a tial rebuild kit for my wastegate?

Wastegates are fairly simple...pull it off the car and pull the top off. Look at the diaphragm inspect it for holes/tears (be careful with it though!!). Also check the spring out make sure it's acting like a spring (no binding, unlikely but you never know). If it all checks out I'm willing to bet your wastegate is fine and the problem is else where (boost controller/vacuum line)
__________________
go ahead...change yours too now; again
lVlemphizStylez is offline   Reply With Quote
Old 07-26-2010, 06:36 PM   #3 (permalink)
SRTforums Member
 
Join Date: Jun 2008
Member Number: 64835
Location: TN
Posts: 1,760
Default

Yeah I'm going to swap the vac lines out here in a bit and hopefully that will fix it. If not I guess I'll take it off tomorrow. I just had it off this weekend and put a stiffer spring in it. Everything was fine til I started it Sunday morning and turned the boost down, ever since it has acted weird.
solarsrt4tn is offline   Reply With Quote
Old 07-26-2010, 08:53 PM   #4 (permalink)
SRTforums Member
 
Join Date: Jun 2008
Member Number: 64835
Location: TN
Posts: 1,760
Default

I really don't see how this belongs in this area since it's a problem with an EXTERNAL wastegate and has nothing to do with a stock part or a dealer for that matter. Anyway, I rearranged the vac lines and it didn't help at all. I guess I'll rip the wastegate off tomorrow and have a look at it.
solarsrt4tn is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 07:38 PM.



(C) SRTforums.com

Search Engine Friendly URLs by vBSEO 3.3.2