Car won't stop accelerating!!! - Dodge SRT Forum
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 08-28-2011, 05:38 AM Thread Starter
SRTforums Member
 
Join Date: Jun 2011
Location: Elgin, IL
Posts: 54
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Car won't stop accelerating!!!

I was driving my car the other day and it was fine but than as i put it in neutral the rpms would stay at 2500-3500 rpm. Then when it was in gear it felt like it wouldn't stop accelerating. I checked the tps wiring by slightly wiggleing the wires and the idle would jump around. I replaced the harness and the car ran perfect for a couple days. Tonight i drove it and as i downshifted into 3rd and then let of the gas and wouldnt stop again i dropped it in neutral and went up to 6000 rpm so i shut the car off and checked everything it all seemed fine so after a while with it off it went back down to idleing at 2500-3000 rpm and drove home like that but as i drove home it went back to normal. I'm gonna do a boost leak test later today see if i find anything. Has anyone had this problem before???


03' Neon Srt-4 E85
Stage 1 Kit, K&N Drop in, Mpx Side Exhaust, Deatsch Werks 1000cc Injectors, Walbro 255 Fuel Pump, DSP, Koyo Radiator, ACT HDSS, BC coilovers, Needswings Hard pipe, HKS SSQ, N2MB WOT Box, Mpx BFMI, 6000k HID's, Yellow fogs, Drag Dr 31 Wheels
Jr_Castillo847 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 08-28-2011, 06:28 AM
Supporting Vendor (Gold)
SRT of the Month
 
ERABBIT23's Avatar
 
Join Date: Mar 2006
Location: Ellwood City,PA
Posts: 5,120
Mentioned: 0 Post(s)
Tagged: 1 Thread(s)
Quoted: 0 Post(s)
Lifetime Premium Member
Bad vacuum leak. Check for boost leaks we had this happen to us the other day blew a intake manifold gasket out on the shop car at the track had to drive it home 35 miles idleing at 4,000 RPM. Drives nice on the highway tho cruising at 2,500 RPM in 5th gear at 66 MPH like cruise control!

World's Fastest 5 Speed SRT-4 and Only One in the 9's 9.87@149
Proven Track Passes, Not Talked About Dreams Since 2008
http://www.youtube.com/user/ERABBIT23

Last edited by ERABBIT23; 08-28-2011 at 06:31 AM.
ERABBIT23 is offline  
post #3 of 8 (permalink) Old 08-28-2011, 07:20 AM
SRTforums Member
 
Rhunter's Avatar
 
Join Date: Dec 2005
Location: LOCASH
Posts: 10,624
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
You probably need a new Air Idle Control Valve.



Nunca Levanta
A Lotta turbo! Small motor! And a Go Pedal!!

Lets re-grow the community! Subscribe to: www.elralforacingmedia.com
Rhunter is offline  
post #4 of 8 (permalink) Old 08-28-2011, 07:32 AM
SRTforums Member
 
MrSRT4309's Avatar
 
Join Date: Nov 2007
Location: I dont know
Posts: 1,199
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
unplug the battery and plug it back, that happened 2 me once i restarted it like that and went away
MrSRT4309 is offline  
post #5 of 8 (permalink) Old 08-28-2011, 05:39 PM
SRTforums Member
 
fivetoez's Avatar
 
Join Date: Apr 2004
Location: Central Ct.
Posts: 4,099
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
IAC wires may be broken internally @ the connector..it's common.

_____5TOEZ______ 1967 Cadillac Calais 429 2dr.,.... 1967 Chevelle 4sp. Conv.... ,1978 Dodge 318 "Factory Custom"van.,..... 2004 Dodge Srt-4,Stage1.5(E-Blue) & a couple motorcycles.
fivetoez is offline  
post #6 of 8 (permalink) Old 08-28-2011, 11:17 PM Thread Starter
SRTforums Member
 
Join Date: Jun 2011
Location: Elgin, IL
Posts: 54
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
i checked the iac connector and its missing the red lock clip is there any way to check the iac?


03' Neon Srt-4 E85
Stage 1 Kit, K&N Drop in, Mpx Side Exhaust, Deatsch Werks 1000cc Injectors, Walbro 255 Fuel Pump, DSP, Koyo Radiator, ACT HDSS, BC coilovers, Needswings Hard pipe, HKS SSQ, N2MB WOT Box, Mpx BFMI, 6000k HID's, Yellow fogs, Drag Dr 31 Wheels
Jr_Castillo847 is offline  
post #7 of 8 (permalink) Old 08-29-2011, 05:33 AM
Premium Member (Lifetime)
SRTotM Moderator
 
Bad98rt's Avatar
 
Join Date: Apr 2010
Location: Kalamazoo, Mi
Posts: 5,597
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
im with erabbit check for vacuum leaks i ve seen this happen a few times

Huge thanks to Chris, Bill, And Bob @MAPerformane for 95% of all my parts

Huge Thanks to Kevin Warren For.. Many many things

MAP EF4 stock block, stock head
452whp on EMS at 26 psi
100&92 octane mix

Fully built long block and big numbers coming!
Bad98rt is offline  
post #8 of 8 (permalink) Old 08-29-2011, 09:52 AM
SRTforums Member
 
prevrexowner's Avatar
 
Join Date: Nov 2008
Location: Warner Robins
Posts: 4,122
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Hopefully, the OP will give us an update. I'm having the same problem.

http://www.srtforums.com/forums/f24/...85/index2.html Post#18 = truth for stock vs. all others.

http://www.gnttype.org/techarea/turbo/intercooler.html

Also, Duster360 knows his $hit!
prevrexowner is offline  
Sponsored Links
Advertisement
 
Reply

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome