WTF is my car doing? - Dodge SRT Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 24 (permalink) Old 02-26-2013, 05:56 PM Thread Starter
SRTforums Member
 
RTdodgeneon's Avatar
 
Join Date: Jul 2012
Location: prescott az
Posts: 190
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Angry WTF is my car doing?

its been doing this since i got it running. i have swapped 2 coils, 4 wire sets, changed the spark plug gap from .35 to .38 to. 30 and still no changes. im running stock coil with granatelli wires now. with stock copper champions and has the hiccup at idle the most plug while having it held at a rpm under no load just like this video


just like that guys car but maybe a little more than him.

As for my mods i have a stage 2 kit no toys, 15lbs, stock coil with ganatelli wires, Mpx bfmic, 3 in 02 and dp, ported intake ports, hard pipes, bwoody CC with mpx cv, PCM boost, pretty much a stock stage 2 kit with simple bolt ons. so maybe its an injector? or teh plugs? was thinking of NGK iridiums, but wanted to get some professional suggestions before i throw money in it
RTdodgeneon is offline  
Sponsored Links
Advertisement
 
post #2 of 24 (permalink) Old 02-26-2013, 05:58 PM
SRTforums Member
 
CarbonSRT's Avatar
 
Join Date: Mar 2010
Location: Grand Rapids
Posts: 556
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Trouble codes?

I just wanna go fast!
CarbonSRT is offline  
post #3 of 24 (permalink) Old 02-26-2013, 06:20 PM Thread Starter
SRTforums Member
 
RTdodgeneon's Avatar
 
Join Date: Jul 2012
Location: prescott az
Posts: 190
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
also the vacum at idle is 20 and tried to boost leak test with my new mpx one with the key on and only leaks from the holes on the MOPAR BOV. what am i doing wrong here?
RTdodgeneon is offline  
post #4 of 24 (permalink) Old 02-26-2013, 06:23 PM Thread Starter
SRTforums Member
 
RTdodgeneon's Avatar
 
Join Date: Jul 2012
Location: prescott az
Posts: 190
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
po522 and po663
RTdodgeneon is offline  
post #5 of 24 (permalink) Old 02-26-2013, 06:26 PM Thread Starter
SRTforums Member
 
RTdodgeneon's Avatar
 
Join Date: Jul 2012
Location: prescott az
Posts: 190
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
one is for the key which is no changes and the other is for the stock oil sending unit cause i have it off due to my Mopar oil psi gauge
RTdodgeneon is offline  
post #6 of 24 (permalink) Old 02-26-2013, 07:27 PM
Premium Member
 
ACRMAG's Avatar
 
Join Date: Jul 2010
Location: Murrieta, CA
Posts: 374
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Premium Member
So it ran fine till you cleaned your injectors. What did you do to clean them or who did you send the to?

Sold: 2005 SRT-4 ACR Stone White
Dismantled: 2000 Neon: Project SRT-4 full swap
Current 2003 SRT-4
ACRMAG is offline  
post #7 of 24 (permalink) Old 02-26-2013, 07:35 PM
SRTforums Member
 
NeOnDrAgOn's Avatar
 
Join Date: Jul 2010
Location: King George, VA
Posts: 881
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
My car kinda has that little pop on the idle (hear in the exhaust and inside), but i am pretty sure that is normal. The mid range breaking up still sounds like ign? You sure all the parts swapped are ok and in working order?

05 Black,Full 3inch exhaust, BWS3 47#,Ported and polished, Duster360's injectors and tune
Realtune LCA's Bushing= Best mod since the DSP.

Quote:
Originally Posted by never2muchboost View Post
hadoukens will be shat

Last edited by NeOnDrAgOn; 02-26-2013 at 07:37 PM.
NeOnDrAgOn is offline  
post #8 of 24 (permalink) Old 02-26-2013, 09:27 PM
SRTforums Member
 
CarbonSRT's Avatar
 
Join Date: Mar 2010
Location: Grand Rapids
Posts: 556
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
WTF is my car doing?

Does it drive ok?


Sent from

I just wanna go fast!
CarbonSRT is offline  
post #9 of 24 (permalink) Old 02-26-2013, 09:50 PM Thread Starter
SRTforums Member
 
RTdodgeneon's Avatar
 
Join Date: Jul 2012
Location: prescott az
Posts: 190
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
it drives okay, just idle and no load rpm it does it and is VERY annoying to me. i looked on my scan gauge at the throttle % and voltage stayed the same so maybe a cam or crank sensor?
but ive noticed a little more lately is sometimes when i rev it up or givr iit throttle it bogs down or poops feels like
RTdodgeneon is offline  
post #10 of 24 (permalink) Old 02-26-2013, 10:19 PM
SRTforums Member
 
04PAcruz'n's Avatar
 
Join Date: Feb 2004
Location: Collegeville PA
Posts: 1,378
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I would run NGK 4306s NOT iridiums @ .35 gap. when @ idle try to wiggle the TPS and IAC wires to see if there is any change in idle sound.

Mods:
FM E3, Stage 3 w/o toys, JMB Ported IM+PTP 55mm TB, PTP charge pipe, Thermal R&D exhaust w/cat, Mopar CAI, Spearco DF-IC, Samco IC hoses.
Mopar Stage 1 suspension (springs+sways), rear tension struts, Mopar front STB, Pwerks rear STB, mm inserts (street)
Mopar STS, Mopar BOV, JMB catchcan, Pwerks grounding kit
04PAcruz'n is offline  
post #11 of 24 (permalink) Old 02-26-2013, 10:49 PM
SRTforums Member
 
Join Date: Sep 2003
Location: Tucson
Posts: 6,070
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 20 Post(s)
Maybe imbalanced injectors?

2005 SRT-4, hole in the block, rebuild in progress
2002 Camaro SS M6, It's alive!
2003 SRT-4 Sold!
enginjoe is online now  
post #12 of 24 (permalink) Old 02-26-2013, 10:49 PM Thread Starter
SRTforums Member
 
RTdodgeneon's Avatar
 
Join Date: Jul 2012
Location: prescott az
Posts: 190
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
so ask for 4306 or is that a part #?
RTdodgeneon is offline  
post #13 of 24 (permalink) Old 02-26-2013, 10:54 PM
Premium Member (Lifetime)
SRT of the Month
 
underSRTarmor's Avatar
 
Join Date: Aug 2005
Location: N. La/ E. Tx
Posts: 9,177
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Lifetime Premium Member
Re: WTF is my car doing?

Tell them u want 4 ngk 4306 plugs

Then when they ask for what car u say I asked for ngk 4306 lol

TUNED By MindMelt101
MyBuild Thread
10.99 @132.23 1.70 60ft 27 psi
Need Fuel setup ideas click here
Props go out to:
Mindmelt101, Tuner Geeks, Act, Wikyd Performance, Pwerks
underSRTarmor is offline  
post #14 of 24 (permalink) Old 02-26-2013, 11:00 PM Thread Starter
SRTforums Member
 
RTdodgeneon's Avatar
 
Join Date: Jul 2012
Location: prescott az
Posts: 190
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
lol ill do that and see how it goes
RTdodgeneon is offline  
post #15 of 24 (permalink) Old 02-27-2013, 07:46 AM
SRTforums Member
 
Join Date: Sep 2003
Location: Tucson
Posts: 6,070
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 20 Post(s)
Quote:
Originally Posted by underSRTarmor View Post
Tell them u want 4 ngk 4306 plugs

Then when they ask for what car u say I asked for ngk 4306 lol
...and then the girl behind the counter will say, I really need to get the car information...

2005 SRT-4, hole in the block, rebuild in progress
2002 Camaro SS M6, It's alive!
2003 SRT-4 Sold!
enginjoe is online now  
Sponsored Links
Advertisement
 
Reply

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome