WTF is my car doing? - SRT Forums - SRT4, SRT6, SRT8, SRT10 & Dodge Forum
 
 


Go Back   SRT Forums - SRT4, SRT6, SRT8, SRT10 & Dodge Forum > SRT-4 Technical Discussion > Performance Modifications

SrtForums.com is the premier Dodge SRT Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 02-26-2013, 04:56 PM   #1 (permalink)
SRTforums Member
 
RTdodgeneon's Avatar
 
Join Date: Jul 2012
Member Number: 89857
Location: prescott az
Posts: 190
Angry WTF is my car doing?

its been doing this since i got it running. i have swapped 2 coils, 4 wire sets, changed the spark plug gap from .35 to .38 to. 30 and still no changes. im running stock coil with granatelli wires now. with stock copper champions and has the hiccup at idle the most plug while having it held at a rpm under no load just like this video


just like that guys car but maybe a little more than him.

As for my mods i have a stage 2 kit no toys, 15lbs, stock coil with ganatelli wires, Mpx bfmic, 3 in 02 and dp, ported intake ports, hard pipes, bwoody CC with mpx cv, PCM boost, pretty much a stock stage 2 kit with simple bolt ons. so maybe its an injector? or teh plugs? was thinking of NGK iridiums, but wanted to get some professional suggestions before i throw money in it
RTdodgeneon is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-26-2013, 04:58 PM   #2 (permalink)
SRTforums Member
 
CarbonSRT's Avatar
 
Join Date: Mar 2010
Member Number: 78159
Location: Grand Rapids
Posts: 556
Default

Trouble codes?
__________________
I just wanna go fast!
CarbonSRT is offline   Reply With Quote
Old 02-26-2013, 05:20 PM   #3 (permalink)
SRTforums Member
 
RTdodgeneon's Avatar
 
Join Date: Jul 2012
Member Number: 89857
Location: prescott az
Posts: 190
Default

also the vacum at idle is 20 and tried to boost leak test with my new mpx one with the key on and only leaks from the holes on the MOPAR BOV. what am i doing wrong here?
RTdodgeneon is offline   Reply With Quote
Old 02-26-2013, 05:23 PM   #4 (permalink)
SRTforums Member
 
RTdodgeneon's Avatar
 
Join Date: Jul 2012
Member Number: 89857
Location: prescott az
Posts: 190
Default

po522 and po663
RTdodgeneon is offline   Reply With Quote
Old 02-26-2013, 05:26 PM   #5 (permalink)
SRTforums Member
 
RTdodgeneon's Avatar
 
Join Date: Jul 2012
Member Number: 89857
Location: prescott az
Posts: 190
Default

one is for the key which is no changes and the other is for the stock oil sending unit cause i have it off due to my Mopar oil psi gauge
RTdodgeneon is offline   Reply With Quote
Old 02-26-2013, 06:27 PM   #6 (permalink)
Premium Member
 
ACRMAG's Avatar
 
Join Date: Jul 2010
Member Number: 80310
Location: Murrieta, CA
Posts: 372
Premium Member
Default

So it ran fine till you cleaned your injectors. What did you do to clean them or who did you send the to?
__________________
Sold: 2005 SRT-4 ACR Stone White
Dismantled: 2000 Neon: Project SRT-4 full swap
Current 2003 SRT-4
ACRMAG is offline   Reply With Quote
Old 02-26-2013, 06:35 PM   #7 (permalink)
SRTforums Member
 
NeOnDrAgOn's Avatar
 
Join Date: Jul 2010
Member Number: 80191
Location: King George, VA
Posts: 881
Default

My car kinda has that little pop on the idle (hear in the exhaust and inside), but i am pretty sure that is normal. The mid range breaking up still sounds like ign? You sure all the parts swapped are ok and in working order?
__________________
05 Black,Full 3inch exhaust, BWS3 47#,Ported and polished, Duster360's injectors and tune
Realtune LCA's Bushing= Best mod since the DSP.

Quote: Originally Posted by never2muchboost View Post
hadoukens will be shat


Last edited by NeOnDrAgOn; 02-26-2013 at 06:37 PM.
NeOnDrAgOn is offline   Reply With Quote
Old 02-26-2013, 08:27 PM   #8 (permalink)
SRTforums Member
 
CarbonSRT's Avatar
 
Join Date: Mar 2010
Member Number: 78159
Location: Grand Rapids
Posts: 556
Default WTF is my car doing?

Does it drive ok?


Sent from
__________________
I just wanna go fast!
CarbonSRT is offline   Reply With Quote
Old 02-26-2013, 08:50 PM   #9 (permalink)
SRTforums Member
 
RTdodgeneon's Avatar
 
Join Date: Jul 2012
Member Number: 89857
Location: prescott az
Posts: 190
Default

it drives okay, just idle and no load rpm it does it and is VERY annoying to me. i looked on my scan gauge at the throttle % and voltage stayed the same so maybe a cam or crank sensor?
but ive noticed a little more lately is sometimes when i rev it up or givr iit throttle it bogs down or poops feels like
RTdodgeneon is offline   Reply With Quote
Old 02-26-2013, 09:19 PM   #10 (permalink)
SRTforums Member
 
04PAcruz'n's Avatar
 
Join Date: Feb 2004
Member Number: 8512
Location: Collegeville PA
Posts: 1,377
Default

I would run NGK 4306s NOT iridiums @ .35 gap. when @ idle try to wiggle the TPS and IAC wires to see if there is any change in idle sound.
__________________
Mods:
FM E3, Stage 3 w/o toys, JMB Ported IM+PTP 55mm TB, PTP charge pipe, Thermal R&D exhaust w/cat, Mopar CAI, Spearco DF-IC, Samco IC hoses.
Mopar Stage 1 suspension (springs+sways), rear tension struts, Mopar front STB, Pwerks rear STB, mm inserts (street)
Mopar STS, Mopar BOV, JMB catchcan, Pwerks grounding kit
04PAcruz'n is offline   Reply With Quote
Old 02-26-2013, 09:49 PM   #11 (permalink)
SRTforums Member
 
Join Date: Sep 2003
Member Number: 3797
Location: Tucson
Posts: 6,003
Default

Maybe imbalanced injectors?
__________________
2005 SRT-4, hole in the block, rebuild in progress
2002 Camaro SS M6, It's alive!
2003 SRT-4 Sold!
enginjoe is offline   Reply With Quote
Old 02-26-2013, 09:49 PM   #12 (permalink)
SRTforums Member
 
RTdodgeneon's Avatar
 
Join Date: Jul 2012
Member Number: 89857
Location: prescott az
Posts: 190
Default

so ask for 4306 or is that a part #?
RTdodgeneon is offline   Reply With Quote
Old 02-26-2013, 09:54 PM   #13 (permalink)
Premium Member (Lifetime)
SRT of the Month
 
underSRTarmor's Avatar
 
Join Date: Aug 2005
Member Number: 32888
Location: N. La/ E. Tx
Posts: 9,177
Lifetime Premium Member
Default Re: WTF is my car doing?

Tell them u want 4 ngk 4306 plugs

Then when they ask for what car u say I asked for ngk 4306 lol
__________________
TUNED By MindMelt101
MyBuild Thread
10.99 @132.23 1.70 60ft 27 psi
Need Fuel setup ideas click here
Props go out to:
Mindmelt101, Tuner Geeks, Act, Wikyd Performance, Pwerks
underSRTarmor is offline   Reply With Quote
Old 02-26-2013, 10:00 PM   #14 (permalink)
SRTforums Member
 
RTdodgeneon's Avatar
 
Join Date: Jul 2012
Member Number: 89857
Location: prescott az
Posts: 190
Default

lol ill do that and see how it goes
RTdodgeneon is offline   Reply With Quote
Old 02-27-2013, 06:46 AM   #15 (permalink)
SRTforums Member
 
Join Date: Sep 2003
Member Number: 3797
Location: Tucson
Posts: 6,003
Default

Quote: Originally Posted by underSRTarmor View Post
Tell them u want 4 ngk 4306 plugs

Then when they ask for what car u say I asked for ngk 4306 lol

...and then the girl behind the counter will say, I really need to get the car information...
__________________
2005 SRT-4, hole in the block, rebuild in progress
2002 Camaro SS M6, It's alive!
2003 SRT-4 Sold!
enginjoe is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 01:59 AM.



(C) SRTforums.com

Search Engine Friendly URLs by vBSEO 3.3.2