A little help guys - SRT Forums - SRT4, SRT6, SRT8, SRT10 & Dodge Forum
 
 


Go Back   SRT Forums - SRT4, SRT6, SRT8, SRT10 & Dodge Forum > SRT-4 Technical Discussion > Performance Modifications

SrtForums.com is the premier Dodge SRT Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 11-27-2012, 09:18 AM   #1 (permalink)
SRTforums Member
 
Kiddx's Avatar
 
Join Date: Mar 2012
Member Number: 88431
Location: Winfield Kansas
Posts: 13
Default A little help guys

So I havent had my SRT4 for very long and this is my first turbo car. Recently my car started running like complete crap. I took the car to our local dodge dealership because living in a tiny town no one here would work on a turbo car. They told me I needed new gaskets for my exhaust manifold and a new flange gasket. After 3 weeks with no car and $720 later my car is running amazingly smooth. But there is a catch. At high rpm the car starts to pop at WOT. It almost sounds like its misfiring. I have also noticed that before i had all these problems the car was at very high 10s or 11.1 on the wideband at WOT but now its at 12.8. I do not know what happened because I havent changed anything on the car. Help please?
__________________
Precision 50 Trim @ 22lbs
Kiddx is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-27-2012, 11:14 AM   #2 (permalink)
SRTforums Member
 
thunt's Avatar
 
Join Date: Apr 2011
Member Number: 84153
Location: eastpointe mi
Posts: 261
Default

That popping is it leaning out. Not good. Don't go wot til you figure out why it's leaning out
__________________
Zeta 3.0dbb .63 a/r 22-23 psi
10.5:1 compression motor
M1 meth mix
93 pump

Agp powered
Built by myself
Under turbo666 control
374/365 on the heartbreaker
thunt is offline   Reply With Quote
Old 11-27-2012, 12:36 PM   #3 (permalink)
Fresh Meat Moderator
 
Join Date: Dec 2009
Member Number: 76568
Location: Chicago
Posts: 16,398
Default

Your sig shows a 50 trim. Do you have the supporting mods for it?
tunerlover3 is offline   Reply With Quote
Old 11-27-2012, 12:40 PM   #4 (permalink)
SRTforums Member
 
Join Date: Jan 2011
Member Number: 82584
Location: florida
Posts: 63
Default

What size inj do you have? are you tuned for the .50 trim?
peacockpirate is offline   Reply With Quote
Old 11-27-2012, 03:52 PM   #5 (permalink)
SRTforums Member
 
Join Date: Aug 2012
Member Number: 90281
Location: Around
Posts: 174
Default

Your leaning out and your computer is demanding fuel so it dumps fuel and it is exploding.
Also what wastegate are your running
Bloo magoo is offline   Reply With Quote
Old 11-27-2012, 04:14 PM   #6 (permalink)
Premium Member
 
_Nick_'s Avatar
 
Join Date: Mar 2004
Member Number: 8941
Location: Camarillo, CA
Posts: 7,124
Premium Member
Default

If you had bad gaskets, you had boost leaks. Now that they are fixed, you are boosting more. Now that you are boosting more, your plug gap needs to be reduced.

Boom shakalakka.

LG-P999 using AutoGuide.C


Magoo is talking.about COT, but we havent gotten that far yet.
__________________
20G Stage 3 on E85: New data:384 hp 411 tq

"Maybe I should just stick to bolt-ons." -Hitler

I don't really want to wrench anymore. I'd rather detail.
_Nick_ is online now   Reply With Quote
Old 11-27-2012, 04:16 PM   #7 (permalink)
SRTforums Member
 
Join Date: Aug 2012
Member Number: 90281
Location: Around
Posts: 174
Default

^
Try like a .35 gap
Bloo magoo is offline   Reply With Quote
Old 11-27-2012, 04:35 PM   #8 (permalink)
SRTforums Member
 
Join Date: Nov 2012
Member Number: 91432
Location: Norwalk, Ohio
Posts: 1
Default

Sounds like a bad coil pack. Same thing happened to me after I replace it ran like a charm


Bgabe12 is offline   Reply With Quote
Old 11-27-2012, 07:09 PM   #9 (permalink)
SRTforums Member
 
Join Date: Nov 2012
Member Number: 91308
Location: Mississippi
Posts: 13
Default

Mine pops when I redline, and it's completely stock.
SRT4-Newbie is offline   Reply With Quote
Old 11-27-2012, 07:13 PM   #10 (permalink)
Premium Member (Lifetime)
SRT of the Month
 
underSRTarmor's Avatar
 
Join Date: Aug 2005
Member Number: 32888
Location: N. La/ E. Tx
Posts: 9,181
Lifetime Premium Member
Default

Quote: Originally Posted by Bloo magoo View Post
^
Try like a .35 gap

Omg. This sick ins me. It's .035!!!!!!!!! I see this at least once a week!

= ) have a nice day


__________________
TUNED By MindMelt101
MyBuild Thread
10.99 @132.23 1.70 60ft 27 psi
Need Fuel setup ideas click here
Props go out to:
Mindmelt101, Tuner Geeks, Act, Wikyd Performance, Pwerks, Porting Solutions
underSRTarmor is offline   Reply With Quote
Old 11-27-2012, 08:12 PM   #11 (permalink)
Premium Member
 
_Nick_'s Avatar
 
Join Date: Mar 2004
Member Number: 8941
Location: Camarillo, CA
Posts: 7,124
Premium Member
Default

Quote: Originally Posted by underSRTarmor View Post
Omg. This sick ins me. It's .035!!!!!!!!! I see this at least once a week!

= ) have a nice day



For reals people. .0xx is your gap. BTW, Don't use the ring tool, use the tool with the 90* angle in it to bend the arm, instead of messing with the diode.
__________________
20G Stage 3 on E85: New data:384 hp 411 tq

"Maybe I should just stick to bolt-ons." -Hitler

I don't really want to wrench anymore. I'd rather detail.
_Nick_ is online now   Reply With Quote
Old 11-27-2012, 09:18 PM   #12 (permalink)
Premium Member (Lifetime)
SRT of the Month
 
underSRTarmor's Avatar
 
Join Date: Aug 2005
Member Number: 32888
Location: N. La/ E. Tx
Posts: 9,181
Lifetime Premium Member
Default

Quote: Originally Posted by _Nick_ View Post
For reals people. .0xx is your gap. BTW, Don't use the ring tool, use the tool with the 90* angle in it to bend the arm, instead of messing with the diode.

Diode hahaha

It's the electrode


__________________
TUNED By MindMelt101
MyBuild Thread
10.99 @132.23 1.70 60ft 27 psi
Need Fuel setup ideas click here
Props go out to:
Mindmelt101, Tuner Geeks, Act, Wikyd Performance, Pwerks, Porting Solutions
underSRTarmor is offline   Reply With Quote
Old 11-27-2012, 10:44 PM   #13 (permalink)
SRTforums Member
 
Kiddx's Avatar
 
Join Date: Mar 2012
Member Number: 88431
Location: Winfield Kansas
Posts: 13
Default

Hey, thank all you guys so much for responding and trying to help me out. I gaped my plugs to .035 and ditched my msd plug wires and got some bosch and now the car is running 100% perfect. Oh and someone asked if i had supporting mods... Heres my set up.


-High Flow Cast Stainless Steel Exhaust manifold
-PTE 5031E Turbo - .48housing journal bearing 5 bolt T3 flange
-Custom Cast Turbine Housing
-Tial 38mm External Wastegate
-Stainless Steel 3" 02 Housing
-Stainless dump tube for wastegate discharge
-Aeroquip oil feed and return lines
-CNC machine fittings and flanges
-WERKS Racing FMIC
-WERKS Racing Upper and lower IC pipes W/Tial B.O.V
Diablo DSP w/a WERKS Custom tune
-DW- SRT-4 750cc injectors
-Walbro SRT-4 255lph Fuel Pump upgrade
-MOPAR SRT-4 3 Bar map sensor
-MOPAR SRT-4 3 Bar Tip senosr -Turbo XS Standard Manual Boost Controller
-AEM intake
__________________
Precision 50 Trim @ 22lbs
Kiddx is offline   Reply With Quote
Old 11-27-2012, 10:52 PM   #14 (permalink)
SRTforums Member
 
Join Date: Aug 2012
Member Number: 90281
Location: Around
Posts: 174
Default

I mean correcting me is fine but I don't see why it's such a concerning problem.
Bloo magoo is offline   Reply With Quote
Old 11-27-2012, 11:03 PM   #15 (permalink)
Premium Member (Lifetime)
SRT of the Month
 
underSRTarmor's Avatar
 
Join Date: Aug 2005
Member Number: 32888
Location: N. La/ E. Tx
Posts: 9,181
Lifetime Premium Member
Default

Quote: Originally Posted by Bloo magoo View Post
I mean correcting me is fine but I don't see why it's such a concerning problem.

Do u know the difference in .35 and .035???

Ones bigger than 1/3 the other is smaller than 1/28


__________________
TUNED By MindMelt101
MyBuild Thread
10.99 @132.23 1.70 60ft 27 psi
Need Fuel setup ideas click here
Props go out to:
Mindmelt101, Tuner Geeks, Act, Wikyd Performance, Pwerks, Porting Solutions
underSRTarmor is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 10:14 AM.



(C) SRTforums.com

Search Engine Friendly URLs by vBSEO 3.3.2