flashing check engine light? - SRT Forums - SRT4, SRT6, SRT8, SRT10 & Dodge Forum
 
 


Go Back   SRT Forums - SRT4, SRT6, SRT8, SRT10 & Dodge Forum > SRT-4 Technical Discussion > Performance Modifications

SrtForums.com is the premier Dodge SRT Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 05-22-2010, 08:35 PM   #1 (permalink)
SRTforums Member
 
HUB SRT's Avatar
 
Join Date: Feb 2009
Member Number: 70890
Location: Swanton, OH
Posts: 518
Default flashing check engine light?

So I'm driving my car and just finish getting it tuned 3 day ago... have had no issues... drive to my grandmas which is 80 miles one way... when driving back with about 15 miles left my check engine light is flashing... car sounds and acts fine... then goes away... I check it with my dsp, no codes... and comes back on again... I do a scan while its flashing and no codes pop up... so now I'm stumpped... I turned the car off and back on and hasn't done it again...

Also when I turn the key off then on (not running) my engine light comes on... the car chimes, then the engine light blinks 10 times, then remains solid...

Any ideas guys?
__________________

2005 SRT-4
HUB SRT is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-22-2010, 08:38 PM   #2 (permalink)
SRTforums Member
 
chicken nugget's Avatar
 
Join Date: Jan 2008
Member Number: 60776
Location: mac daddy's
Posts: 4,290
Default

no codes are coming up? sounds odd...
__________________
Nicken Chugget.
chicken nugget is offline   Reply With Quote
Old 05-22-2010, 08:41 PM   #3 (permalink)
SRTforums Member
 
HUB SRT's Avatar
 
Join Date: Feb 2009
Member Number: 70890
Location: Swanton, OH
Posts: 518
Default

I know... didn't do this till I got the tune... think I should contact the person that tuned it? Was done via email with the dsp.
__________________

2005 SRT-4
HUB SRT is offline   Reply With Quote
Old 05-22-2010, 08:47 PM   #4 (permalink)
SRTforums Member
 
chicken nugget's Avatar
 
Join Date: Jan 2008
Member Number: 60776
Location: mac daddy's
Posts: 4,290
Default

they may need a code to help you out...try an autozone or something that will check codes for free and see if any pop up for there machine.
__________________
Nicken Chugget.
chicken nugget is offline   Reply With Quote
Old 05-22-2010, 08:51 PM   #5 (permalink)
SRTforums Member
 
AngrySrt's Avatar
 
Join Date: Feb 2009
Member Number: 71255
Location: maple valley
Posts: 485
Default

sounds like a misfire? thats what is it when im misfiring
__________________
2003 srt-4 stage 0 pcm,ATP 60 trim kit,750s,tial wastegate,agp full race bfmic, agp intake, scan guage, mpx extrude honed mani,mpx 62 mm throttle body, ptp charge pipe,agp up pipe with hks bov, aem wideband, 3 in side exit, ipp coilovers and some sportmaxx wheels, dsp tune and all the help in the world from jon at ptp! great guy!
AngrySrt is offline   Reply With Quote
Old 05-23-2010, 04:17 AM   #6 (permalink)
SRTforums Member
 
HUB SRT's Avatar
 
Join Date: Feb 2009
Member Number: 70890
Location: Swanton, OH
Posts: 518
Default

Quote: Originally Posted by AngrySrt View Post
sounds like a misfire? thats what is it when im misfiring

Idk... I had a bad injector once and thew the misfire code and it blinked, but the engine light stayed and my dsp picked it up. Also the car ran like shit...but the car runs great... gets up to 12o with no easy... we (and the person tuning my car) were dealing with random misfire when the car did a cold start... but he changed the fuel trims and believe bumped up the idle and that seemed to clear it up... I do have new plugs and wires... I have no clue why it did this and won't do it again.
__________________

2005 SRT-4
HUB SRT is offline   Reply With Quote
Old 05-23-2010, 07:10 AM   #7 (permalink)
Fresh Meat Moderator
 
Join Date: Dec 2009
Member Number: 76568
Location: Chicago
Posts: 16,398
Default

Blinking check engine light means cat damage is happening.

You have to have a code. The PCM is not retarded, it stored the code if the CEL is on.

Also it doesnt matter that its on with the key on engine off. Thats normal.
tunerlover3 is offline   Reply With Quote
Old 05-23-2010, 07:24 AM   #8 (permalink)
SRTforums Member
 
Hotrodblack50's Avatar
 
Join Date: May 2010
Member Number: 79141
Location: Sanford, NC
Posts: 102
Default

If you do get a check engine light you can turn the key on and off three time and the code will read where the miles are, will be a P#### code. Then you can look it up online. But a flashing check engine light is a mifire which will ruin you CAT and that cost a lot to replace. Good luck!
Hotrodblack50 is offline   Reply With Quote
Old 05-23-2010, 09:21 AM   #9 (permalink)
SRTforums Member
 
HUB SRT's Avatar
 
Join Date: Feb 2009
Member Number: 70890
Location: Swanton, OH
Posts: 518
Default

Quote: Originally Posted by tunerlover3 View Post
Blinking check engine light means cat damage is happening.

You have to have a code. The PCM is not retarded, it stored the code if the CEL is on.

Also it doesnt matter that its on with the key on engine off. Thats normal.

Well don't care if it there is cat damage... I don't have one, but wonder why its doing it now.
__________________

2005 SRT-4
HUB SRT is offline   Reply With Quote
Old 05-23-2010, 10:37 AM   #10 (permalink)
SRTforums Member
 
Join Date: Dec 2008
Member Number: 69469
Location: St. Charles, MO
Posts: 20
Default

How is your downstream O2 sensor plugged in? Do you have a non-fouler?
tmole57 is offline   Reply With Quote
Old 05-23-2010, 10:46 AM   #11 (permalink)
SRTforums Member
 
BLKDOUTSRT4's Avatar
 
Join Date: Dec 2005
Member Number: 36285
Location: GARLAND
Posts: 11,953
Default

its not just cat damage...it can cause engine damage too....
__________________
Quote: Originally Posted by Alpha-Omega View Post
....yeah, I'm gay and staying home this time

BLKDOUTSRT4 is offline   Reply With Quote
Old 05-23-2010, 10:48 AM   #12 (permalink)
SRTforums Member
 
HUB SRT's Avatar
 
Join Date: Feb 2009
Member Number: 70890
Location: Swanton, OH
Posts: 518
Default

Quote: Originally Posted by tmole57 View Post
How is your downstream O2 sensor plugged in? Do you have a non-fouler?

The guy I got the tune from, said he could elimante the cat code I was getting... p0420. And I never got that code again. But if it blink cause it thinks there is something wrong with the cat, I'm not going to worry.
__________________

2005 SRT-4
HUB SRT is offline   Reply With Quote
Old 05-23-2010, 11:03 AM   #13 (permalink)
SRTforums Member
 
HUB SRT's Avatar
 
Join Date: Feb 2009
Member Number: 70890
Location: Swanton, OH
Posts: 518
Default

Quote: Originally Posted by Hotrodblack50 View Post
If you do get a check engine light you can turn the key on and off three time and the code will read where the miles are, will be a P#### code. Then you can look it up online. But a flashing check engine light is a mifire which will ruin you CAT and that cost a lot to replace. Good luck!

Well I tried this, and its just reads done and the 5 dashes then goes to my mileage.... but is it possible its just on the fritz due there being no cat and with the tune?
__________________

2005 SRT-4
HUB SRT is offline   Reply With Quote
Old 05-23-2010, 11:07 AM   #14 (permalink)
SRTforums Member
 
Hi N Mity's Avatar
 
Join Date: Aug 2005
Member Number: 33036
Location: WA
Posts: 7,221
Default

blinking CEL is not for cat damage, it means that catistrophic(sp) engine damage can happen and engine should be turned off asap. It could be a simple misfire, excess knock, slipped timing belt......etc. It is wierd that it didnt leave a stored code.

Now, with the engine OFF and key ON, the blinking CEL is only normal if you have recently disconnected the battery or removed the ASD relay. It means that the ECU has not checked all the perameters of the emission control systems. You will not be able to pass inspection if the cel is blinking with the key on/engine off. It can take a few hundred miles to reset the blinking cel. It will start all over again if you disconnect the battery.
Hi N Mity is offline   Reply With Quote
Old 05-23-2010, 11:12 AM   #15 (permalink)
SRTforums Member
 
prevrexowner's Avatar
 
Join Date: Nov 2008
Member Number: 68977
Location: Warner Robins
Posts: 4,122
Default

I'm putting money on the coil pack.
prevrexowner is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 04:43 AM.



(C) SRTforums.com

Search Engine Friendly URLs by vBSEO 3.3.2