2003 SRT4 Bushing Came off shift linkage fixed now I cant get into neutral - SRT Forums - SRT4, SRT6, SRT8, SRT10 & Dodge Forum
 
 


Go Back   SRT Forums - SRT4, SRT6, SRT8, SRT10 & Dodge Forum > SRT-4 Technical Discussion > Drivetrain Discussion

SrtForums.com is the premier Dodge SRT Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 11-25-2012, 04:13 PM   #1 (permalink)
SRTforums Member
 
Join Date: Nov 2012
Member Number: 91403
Location: california
Posts: 3
Default 2003 SRT4 Bushing Came off shift linkage fixed now I cant get into neutral

Hello Everyone,
I have a 2003 Dodge SRT4 . The other day while driving I went to shift into 5th gear and the car went into neutral. Got it back into 5th gear and drove it home. I fixed the bushing and linkage (One Closest to Block) and now cant get into neutral . Anyone have any ideas or suggestions. Do you manually have to line up the transmission before hooking the linkage back up? If anyone could help it would be greatly appreciated.
Thanks
covertSRT is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-25-2012, 04:32 PM   #2 (permalink)
SRTforums Member
 
*ALEX*'s Avatar
 
Join Date: Jun 2010
Member Number: 79647
Location: gh illinois
Posts: 1,304
Default

Put new bushins in and drive that's it no
__________________
Quote: Originally Posted by lVlemphizStylez View Post
When I open my hood people think the car is on all kinds of steroids

*ALEX* is offline   Reply With Quote
Old 11-25-2012, 05:00 PM   #3 (permalink)
SRTforums Member
 
Join Date: Nov 2012
Member Number: 91403
Location: california
Posts: 3
Default

It came off at the transmission. Put a new bushing in at the transmission and seems as though its stuck in 3rd/ 4th. No neutral at all. Could it have broken the shift fork when the bushing came off? Or if one cable moves and the other doesn't does the tranny have to be manually lined up at the transmission? The right cable doesnt move at the transmission at all. Is that normal or part of the problem?
covertSRT is offline   Reply With Quote
Old 11-25-2012, 05:31 PM   #4 (permalink)
SRTforums Member
 
SRT-4_2-25-03's Avatar
 
Join Date: Mar 2003
Member Number: 531
Location: Round Rock, Tex
Posts: 1,547
Default

Replace all of your bushings. You have 4 of them. 2 on top of the transmission and 2 at the bottom of your shifter under the center console. Modern performance sells them I did my 2003 SRT-4 a year ago and it feels real good ever since. I thought my transmission broke when the bushing fell apart.


iPod touch using AG Free
__________________
Silver SRT-4 bought 2-25-03 without front plate. My car is so stock. Yes sirey Bob
SRT-4_2-25-03 is offline   Reply With Quote
Old 11-25-2012, 05:32 PM   #5 (permalink)
SRTforums Member
 
SRT-4_2-25-03's Avatar
 
Join Date: Mar 2003
Member Number: 531
Location: Round Rock, Tex
Posts: 1,547
Default

You may have to push in the clutch or roll the car a few inches so you can free up the trans mission.


iPod touch using AG Free
__________________
Silver SRT-4 bought 2-25-03 without front plate. My car is so stock. Yes sirey Bob
SRT-4_2-25-03 is offline   Reply With Quote
Old 11-25-2012, 05:34 PM   #6 (permalink)
SRTforums Member
 
Join Date: Nov 2012
Member Number: 91403
Location: california
Posts: 3
Default

I don't think its the bushing's. The 2 at the shifter are booger bushings and the other 2 at the transmission are stock.
Looking at the car,
The linkage to the left (closest to the block) moves back and forth into 3 positions. The cable on the right doesn't move at all (Stuck)!
Any ideas?
covertSRT is offline   Reply With Quote
Old 11-25-2012, 05:46 PM   #7 (permalink)
SRTforums Member
 
Join Date: Sep 2011
Member Number: 86357
Location: Clarksville, TN
Posts: 39
Default

did you have anything besides 5th gear? I know playing with mine the last few days, the one farthest on the driver side, should move when you move the shifter to the left and right. Mine doesn't seem to move very much, but then again, I know my shift selector is broken... and hoping that is all. I would try to rock the car a bit, if still not working, remove the cable from the trany, and see if you can move it by hand, and then see if its moving from your shifter.
Awoll1 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 05:41 AM.



(C) SRTforums.com

Search Engine Friendly URLs by vBSEO 3.3.2