P0440 Trouble Code - Dodge SRT Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 08-25-2011, 09:56 PM Thread Starter
SRTforums Member
 
Join Date: Jul 2011
Location: St. Louis
Posts: 96
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
P0440 Trouble Code

I just had this code thrown at me earlier today. It's the first time it's happened since I've had the car (bought the car Friday of 8/17). I've done some research and looking around and know about 3 things to try. I just wanted to maybe get some more up to date answers since the other post I found were a little old.

I filled up on gas about 3 days ago. I figured it would throw the code a lot sooner if my gas cap wasn't tight, or am I wrong?

I haven't yet to try resetting my ECU. I'm worried it might mess something else up? Someone calm my nerves about that so I can go try it please.

After I try these, should I delete the code with my DSP and wait a couple day to see if it comes back on? If it comes back on should I take it to a mechanic at that point?

Also, am I save to drive the car (it's my DD) with this code thrown?

Thanks for any and all help.
STL SRT4 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 08-26-2011, 08:02 AM
SRTforums Member
 
Gizmodo's Avatar
 
Join Date: Jan 2005
Location: Minnesota
Posts: 4,524
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Check your fuel cap and unhook the negative on the battery for a few minutes. If it comes back then you have some investigation to do.



DiabloSport tuned by Brian (Mindmelt101) at Drag-On Resources.
Gizmodo is offline  
post #3 of 5 (permalink) Old 08-26-2011, 08:05 AM
Premium Member (Lifetime)
 
Forced InD Dean's Avatar
 
Join Date: Oct 2010
Location: In a House...TX
Posts: 444
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Lifetime Premium Member
Any other codes with P0440 ?

P0440-GENERAL EVAP SYSTEM FAILURE
When Monitored: Engine Running. Fuel Level greater than 12%. Ambient Temperature
between 4°C and 32°C (39°F and 89°F)
Set Condition: The PCM does not see the NVLD switch close during the medium/large
leak test. The PCM will then increase the vacuum supply to the EVAP system by
increasing flow through the EVAP Purge valve. If the switch does not close with an
increase in vacuum, an error is detected. Two Trip Fault.
Check for the following conditions:
- Hoses disconnected or left off
- Holes or cracks
- Loose seal points
- Evidence of damaged components
- Incorrect routing of hoses and tubes
- Fuel Cap left off or bad gasket seal


You will be fine with Disconnecting the Neg terminal to reset the Code, it will not Damage anything

05 Stone White FTW
3"TB HPRacing Exhuast nocat, 3BarM/T, DSP+Zetronics sys, 1025cc, Boomba FR, Wally255+BNF+RL, AGP CCw/CV 2ndCC, SDK MM's&TM, H-Brace TB, New STG3, w/Meth M-05 nozzle 60M/40w
Forced InD Dean is offline  
post #4 of 5 (permalink) Old 08-26-2011, 10:32 AM Thread Starter
SRTforums Member
 
Join Date: Jul 2011
Location: St. Louis
Posts: 96
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Well I went out last night and checked my gas cap. It didn't seem loose or anything, but I went ahead and took it off and re-tightened it and then cleared the code with my DSP. Was this an okay thing to do or should I of disconnected the battery?

I plan on waiting a couple days and if the light doesn't come back on then I'd say I'm good?

If anyone has anymore advice, please let me know. I'm new to these cars and would love to know all I can about them. Thanks.
STL SRT4 is offline  
post #5 of 5 (permalink) Old 08-26-2011, 12:06 PM
SRTforums Member
 
Gizmodo's Avatar
 
Join Date: Jan 2005
Location: Minnesota
Posts: 4,524
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Clearing with the Predator is fine. If the code stays away you should be all set.



DiabloSport tuned by Brian (Mindmelt101) at Drag-On Resources.
Gizmodo is offline  
Sponsored Links
Advertisement
 
Reply

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome