boomba fuel rail - SRT Forums - SRT4, SRT6, SRT8, SRT10 & Dodge Forum
 
 


Go Back   SRT Forums - SRT4, SRT6, SRT8, SRT10 & Dodge Forum > SRT-4 Technical Discussion > Fuel Delivery & Race Fuels

SrtForums.com is the premier Dodge SRT Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 04-05-2012, 09:36 AM   #1 (permalink)
SRTforums Member
 
DavidsSRT-4's Avatar
 
Join Date: Dec 2010
Member Number: 82415
Location: marysville, wa
Posts: 392
Default boomba fuel rail

So I installed a boomba fuel rail yesterday with outthe a return lineline and my car seems to act a little different. I know the stock rail has a diaphragm on it to absorb the fuel pumps surging and the boomba fuel rail doesn't have one. Could this make my car a little erratic at take off? Maybe a return line will fix it?

I have plans in the near future to run a return line with a dw300 pump
__________________

300+hp 360 tq STOCK TURBO!
13.22 at 105mph* (with boost leak)
stage 2 and stuff

THIS YEAR 12's OR BUST!
DavidsSRT-4 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-05-2012, 10:42 AM   #2 (permalink)
Premium Member (Lifetime)
 
Join Date: Feb 2005
Member Number: 24404
Location: United Kingdom
Posts: 2,404
Default

Did you cut a seal on an injector? Did you lube them up a little when you put it back together? I have never had a problem.
__________________
Totally Stock down to the KDW's... Best 1/4 Time
13.771 @ 101.2 MPH 2.113 60ft.
Vipercar93 is offline   Reply With Quote
Old 04-05-2012, 11:00 AM   #3 (permalink)
SRTforums Member
 
racedude1984's Avatar
 
Join Date: Mar 2005
Member Number: 25856
Location: Your nightmares
Posts: 1,621
Default

I ran my boomba for a long time without return line maybe you didn't get an injector seated right.

SCH-I500 using
__________________
Old school!
racedude1984 is offline   Reply With Quote
Old 04-05-2012, 11:57 AM   #4 (permalink)
SRTforums Member
 
DavidsSRT-4's Avatar
 
Join Date: Dec 2010
Member Number: 82415
Location: marysville, wa
Posts: 392
Default

Yes to both I made sure they seated correctly and even cleaned out the intake holes and wiped down the seals. Maybe its in my head. The weather has been crazy at my place heavy rains then sunny days the next day maybe my cars just freaking out a little
__________________

300+hp 360 tq STOCK TURBO!
13.22 at 105mph* (with boost leak)
stage 2 and stuff

THIS YEAR 12's OR BUST!
DavidsSRT-4 is offline   Reply With Quote
Old 04-05-2012, 12:11 PM   #5 (permalink)
Premium Member (Lifetime)
 
Join Date: Feb 2005
Member Number: 24404
Location: United Kingdom
Posts: 2,404
Default

How did you clean the holes? You might have accidentally caused an injector to dribble.
__________________
Totally Stock down to the KDW's... Best 1/4 Time
13.771 @ 101.2 MPH 2.113 60ft.
Vipercar93 is offline   Reply With Quote
Old 04-05-2012, 02:47 PM   #6 (permalink)
SRTforums Member
 
DavidsSRT-4's Avatar
 
Join Date: Dec 2010
Member Number: 82415
Location: marysville, wa
Posts: 392
Default

Finger rags a pic and brake clean only on the holes I wiped the o-rings with a rag and hands
__________________

300+hp 360 tq STOCK TURBO!
13.22 at 105mph* (with boost leak)
stage 2 and stuff

THIS YEAR 12's OR BUST!
DavidsSRT-4 is offline   Reply With Quote
Old 04-05-2012, 03:41 PM   #7 (permalink)
Premium Member (Lifetime)
 
Join Date: Feb 2005
Member Number: 24404
Location: United Kingdom
Posts: 2,404
Default

My bet is you damaged the injector with the pic, causing the injector to dribble. Those holes are fairly precise. Fueling wise under power I don't think it's as much of an issue, just causes drive-ability problems since the nozzle cannot atomize the fuel right under light cycles. Either that or you pushed debris into the injector. Your problem defo sounds like an injector acting funny IMO. There should be enough volume in the boomba rail to not have to worry too much about the pump pulses.
__________________
Totally Stock down to the KDW's... Best 1/4 Time
13.771 @ 101.2 MPH 2.113 60ft.
Vipercar93 is offline   Reply With Quote
Old 04-05-2012, 05:43 PM   #8 (permalink)
SRTforums Member
 
DavidsSRT-4's Avatar
 
Join Date: Dec 2010
Member Number: 82415
Location: marysville, wa
Posts: 392
Default

No no no. I didn't touch either opening of the fuel injectors only the o-rings and the intake manifold holes that the injectors go into
__________________

300+hp 360 tq STOCK TURBO!
13.22 at 105mph* (with boost leak)
stage 2 and stuff

THIS YEAR 12's OR BUST!
DavidsSRT-4 is offline   Reply With Quote
Old 04-11-2012, 02:22 PM   #9 (permalink)
SRTforums Member
 
DavidsSRT-4's Avatar
 
Join Date: Dec 2010
Member Number: 82415
Location: marysville, wa
Posts: 392
Default

Could a fouled spark plug cause a problem? Lol
__________________

300+hp 360 tq STOCK TURBO!
13.22 at 105mph* (with boost leak)
stage 2 and stuff

THIS YEAR 12's OR BUST!
DavidsSRT-4 is offline   Reply With Quote
Old 04-21-2012, 12:34 PM   #10 (permalink)
SRTforums Member
 
Salty SRT's Avatar
 
Join Date: Feb 2008
Member Number: 61967
Location: Santa Cruz
Posts: 352
Default

To the OP, I seem to have the same/similar problem. When the car is cold, it just seems to bog when you go to take off. I have been meaning to swap back to the stock rail, and then back again to see if it is the rail causing the problem.
Salty SRT is offline   Reply With Quote
Old 04-21-2012, 12:53 PM   #11 (permalink)
SRTForums Member
2011 Calendar Car
 
Topsey_kretts's Avatar
 
Join Date: Jan 2010
Member Number: 77321
Location: Daytona Beach
Posts: 1,311
Default

when i put the boomba on my car, i couldnt tell any difference. Replace teh spark plugs and see if that fixes it..
__________________
Wait a minute, Doc. Ah... Are you telling me that you built a time machine... out of a DeLorean?
Topsey_kretts is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 03:37 PM.



(C) SRTforums.com

Search Engine Friendly URLs by vBSEO 3.3.2