boost problems - SRT Forums - SRT4, SRT6, SRT8, SRT10 & Dodge Forum
 
 


Go Back   SRT Forums - SRT4, SRT6, SRT8, SRT10 & Dodge Forum > SRT-4 Technical Discussion > Engine/Turbos/Ignition

SrtForums.com is the premier Dodge SRT Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 11-19-2012, 07:55 AM   #1 (permalink)
SRTforums Member
 
Join Date: Nov 2012
Member Number: 91353
Location: seven valleys
Posts: 8
Default boost problems

I just picked up my 04 srt neon from the dealership this past friday. Car runs great but I'm having problems with the boost. Its only making between 8-10 lbs of boost i checked for vacume leaks and didnt find anything and adjusted the wastegate still no difference. Any ideas of what could be wrong? Maybe boost leak but where?
elecbluesrt4 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-19-2012, 09:09 AM   #2 (permalink)
SRTforums Member
 
silver_ek's Avatar
 
Join Date: Jan 2008
Member Number: 60962
Location: texas
Posts: 2,085
Default

check your intercooler pipes.
__________________
"Duster360 knows his $hit"
silver_ek is offline   Reply With Quote
Old 11-19-2012, 11:02 AM   #3 (permalink)
SRTforums Member
 
Join Date: Nov 2012
Member Number: 91353
Location: seven valleys
Posts: 8
Default

Thanks ill check it out.
elecbluesrt4 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 11:39 AM.



(C) SRTforums.com

Search Engine Friendly URLs by vBSEO 3.3.2