License plate light fuse location?! - Dodge SRT Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 05-04-2011, 11:19 PM Thread Starter
SRTforums Member
 
ZETA2.8's Avatar
 
Join Date: Nov 2007
Location: Hawaii
Posts: 194
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
License plate light fuse location?!

I cant get my license plate light to turn on?! I tried replacing the light already. From: (BTW)

Super Bright LEDs - Miniature Wedge Base Bulbs

I tried looking at the back of the panel but its kind of hard to read..I tried swapping some fuse amps around no luck. anyone know exactly where the fuse is located. thanks



Tuned by Nigel (turbo666)
403whp 402wtq @25psi 92oct.
451whp 455wtq @27psi C16
MY MODZ MY SHORT FILM MY DYNO VID
ZETA2.8 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 05-05-2011, 04:50 AM Thread Starter
SRTforums Member
 
ZETA2.8's Avatar
 
Join Date: Nov 2007
Location: Hawaii
Posts: 194
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
bump* sum1 help me out...Its the only light thats not turning on, so it cant be on the same fuse as my tail lights..



Tuned by Nigel (turbo666)
403whp 402wtq @25psi 92oct.
451whp 455wtq @27psi C16
MY MODZ MY SHORT FILM MY DYNO VID
ZETA2.8 is offline  
post #3 of 5 (permalink) Old 05-05-2011, 05:04 AM
SRTforums Member
 
Tony S.'s Avatar
 
Join Date: Aug 2006
Location: IL
Posts: 223
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
It is the same fuse as the parking lights. With LED's you want to pull the bulb and rotate it 180 degrees and plug it back in if it doesn't come on with the first try.


DS Predator, E85 Tune, Maxxfab 02 housing, MPx catless exhaust, AGP dogbones, FM wastegate, AGP hardpipe, AGP return line, PTP fuel pump rewire, Walbro 255, AGP 750 cc injectors, 180 thermostat, HKS SSQ, Magnecore wires, AGP CAI, MPx BFMIC, Maddog 58% STS, AGP Coilovers, AEM UGEO, Aeroforce ScanGauge 12.59@110.6

12.59@110.6
Tony S. is offline  
post #4 of 5 (permalink) Old 05-05-2011, 07:42 AM Thread Starter
SRTforums Member
 
ZETA2.8's Avatar
 
Join Date: Nov 2007
Location: Hawaii
Posts: 194
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by Tony S. View Post
It is the same fuse as the parking lights. With LED's you want to pull the bulb and rotate it 180 degrees and plug it back in if it doesn't come on with the first try.
Thanks ill try that..I figured it didnt matter which way you had to put it in. And whats considered "parking lights" on our car anyway?



Tuned by Nigel (turbo666)
403whp 402wtq @25psi 92oct.
451whp 455wtq @27psi C16
MY MODZ MY SHORT FILM MY DYNO VID
ZETA2.8 is offline  
post #5 of 5 (permalink) Old 05-06-2011, 09:30 AM
SRTforums Member
 
rosejm's Avatar
 
Join Date: Sep 2005
Location: Valpo, IN
Posts: 1,367
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Maybe try a $1 regular bulb? You might have a dead-on-arrival LED.
Dunno that I've heard of that before, but it's possible.

Have you checked the wiring/socket to see if it has power?
At least that way you can determine if it's the bulb, socket or something farther upstream like a fuse or broken wire.


rosejm is offline  
Sponsored Links
Advertisement
 
Reply

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome