License plate light fuse location?! - SRT Forums - SRT4, SRT6, SRT8, SRT10 & Dodge Forum
 
 


Go Back   SRT Forums - SRT4, SRT6, SRT8, SRT10 & Dodge Forum > SRT-4 Technical Discussion > SRT-4 Discussion

SrtForums.com is the premier Dodge SRT Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 05-04-2011, 10:19 PM   #1 (permalink)
SRTforums Member
 
ZETA2.8's Avatar
 
Join Date: Nov 2007
Member Number: 59299
Location: Hawaii
Posts: 194
Default License plate light fuse location?!

I cant get my license plate light to turn on?! I tried replacing the light already. From: (BTW)

Super Bright LEDs - Miniature Wedge Base Bulbs

I tried looking at the back of the panel but its kind of hard to read..I tried swapping some fuse amps around no luck. anyone know exactly where the fuse is located. thanks
__________________


Tuned by Nigel (turbo666)
403whp 402wtq @25psi 92oct.
451whp 455wtq @27psi C16
MY MODZ MY SHORT FILM MY DYNO VID
ZETA2.8 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-05-2011, 03:50 AM   #2 (permalink)
SRTforums Member
 
ZETA2.8's Avatar
 
Join Date: Nov 2007
Member Number: 59299
Location: Hawaii
Posts: 194
Default

bump* sum1 help me out...Its the only light thats not turning on, so it cant be on the same fuse as my tail lights..
__________________


Tuned by Nigel (turbo666)
403whp 402wtq @25psi 92oct.
451whp 455wtq @27psi C16
MY MODZ MY SHORT FILM MY DYNO VID
ZETA2.8 is offline   Reply With Quote
Old 05-05-2011, 04:04 AM   #3 (permalink)
SRTforums Member
 
Tony S.'s Avatar
 
Join Date: Aug 2006
Member Number: 45401
Location: IL
Posts: 223
Default

It is the same fuse as the parking lights. With LED's you want to pull the bulb and rotate it 180 degrees and plug it back in if it doesn't come on with the first try.
__________________

DS Predator, E85 Tune, Maxxfab 02 housing, MPx catless exhaust, AGP dogbones, FM wastegate, AGP hardpipe, AGP return line, PTP fuel pump rewire, Walbro 255, AGP 750 cc injectors, 180 thermostat, HKS SSQ, Magnecore wires, AGP CAI, MPx BFMIC, Maddog 58% STS, AGP Coilovers, AEM UGEO, Aeroforce ScanGauge 12.59@110.6

12.59@110.6
Tony S. is offline   Reply With Quote
Old 05-05-2011, 06:42 AM   #4 (permalink)
SRTforums Member
 
ZETA2.8's Avatar
 
Join Date: Nov 2007
Member Number: 59299
Location: Hawaii
Posts: 194
Default

Quote: Originally Posted by Tony S. View Post
It is the same fuse as the parking lights. With LED's you want to pull the bulb and rotate it 180 degrees and plug it back in if it doesn't come on with the first try.

Thanks ill try that..I figured it didnt matter which way you had to put it in. And whats considered "parking lights" on our car anyway?
__________________


Tuned by Nigel (turbo666)
403whp 402wtq @25psi 92oct.
451whp 455wtq @27psi C16
MY MODZ MY SHORT FILM MY DYNO VID
ZETA2.8 is offline   Reply With Quote
Old 05-06-2011, 08:30 AM   #5 (permalink)
SRTforums Member
 
rosejm's Avatar
 
Join Date: Sep 2005
Member Number: 33812
Location: Valpo, IN
Posts: 1,367
Default

Maybe try a $1 regular bulb? You might have a dead-on-arrival LED.
Dunno that I've heard of that before, but it's possible.

Have you checked the wiring/socket to see if it has power?
At least that way you can determine if it's the bulb, socket or something farther upstream like a fuse or broken wire.
__________________

rosejm is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 07:53 AM.



(C) SRTforums.com

Search Engine Friendly URLs by vBSEO 3.3.2