AC kicking on and off too fast and not cooling good? - SRT Forums - SRT4, SRT6, SRT8, SRT10 & Dodge Forum
 
 


Go Back   SRT Forums - SRT4, SRT6, SRT8, SRT10 & Dodge Forum > SRT-4 Technical Discussion > SRT-4 Discussion

SrtForums.com is the premier Dodge SRT Forum on the internet. Registered Users do not see the above ads.
Closed Thread
 
LinkBack Thread Tools Display Modes
Old 06-19-2006, 02:59 PM   #1 (permalink)
SRTforums Member
 
Bflaker's Avatar
 
Join Date: Jul 2005
Member Number: 30883
Location: Clarksburg, WV
Posts: 1,281
Default AC kicking on and off too fast and not cooling good?

Hey guys and gals. I'm having some trouble with the AC on my 05 Dodge SRT-4. We hooked it up to our machine at work and found it only had a 1/2 pound of freon in it. We filled it back up to the recommended 1.5 lbs and rechecked for leaks and proper cooling. Couldn't find any leaks, but the compressor keeps kicking out at only 100psi. It acts like the high pressure switch is bad, but we can't even find one on the car. Does anyone have the Dodge Service manual with diagnostics for the AC? I don't want to buy one just for this one problem. All help would be greatly appreciated. Thanks. As far as warranty goes, I don't want to take it in to the stealership, due to all the mods I have done to the car. I know the first words out of there mouth will be "Warrany Voided". Thanks again for all help.
__________________

2003 Acura RSX Type-S: 312whp 256wtq
2005 Dodge Neon SRT-4: 276whp 343wtq(SOLD)
Bflaker is offline  
Sponsored Links
Advertisement
 
Old 06-19-2006, 03:59 PM   #2 (permalink)
SRTforums Member
 
bannanasrfun's Avatar
 
Join Date: Oct 2004
Member Number: 18576
Location: oldsmar fl
Posts: 492
Default

get the ac condensor computer reflashed had to have the same thing redone to my ram
__________________
::
bannanasrfun is offline  
Old 06-19-2006, 04:08 PM   #3 (permalink)
SRTforums Member
 
thepowertowin's Avatar
 
Join Date: Jul 2004
Member Number: 13897
Location: Missouri
Posts: 19,321
Default

Quote: Originally Posted by bannanasrfun
get the ac condensor computer reflashed had to have the same thing redone to my ram

Different problem. That one was w/ the condensor fan blowing a fuse because the fan motor would get moisture in it. They also flashed the controller.

Different problem all together.
__________________

Thinking of starting a "scammed by" thread? If you sent the paypal as a "gift" don't even bother... no one feels sorry for you.
thepowertowin is offline  
Old 06-19-2006, 04:16 PM   #4 (permalink)
SRTforums Member
 
thepowertowin's Avatar
 
Join Date: Jul 2004
Member Number: 13897
Location: Missouri
Posts: 19,321
Default

HEATING-A/C SYSTEM
A/C SYSTEM Item Description Notes

Freeze-up Control - 2.4L and RHD models Evaporator temperature sensor Input to PCM, evaporator mounted, cycles clutch off below 1° C (34° F), cycles back on above 7.2° C (45° F)


Low psi Control - 2.4L and RHD models A/C low pressure switch Input to PCM, A/C expansion valve mounted - opens below 96 kPa (14 psi) - resets above 234 - 262 kPa (34 - 38 psi)

High psi Control A/C high pressure switch Input to PCM, A/C Compressor mounted - opens at discharge pressure above 3100 - 3375 kPa (450 - 490 psi) - resets at 1860 - 2275 kPa (270 - 330 psi)

Refrigerant Charge Capacity Refer to the A/C Underhood Specification Label located in the engine compartment R-134a refrigerant

A/C Clutch Coil Draw Denso 10S15 – 2.5 amps @ 12Vą 0.5V @ 21° C (70° F) Denso 10S17 – 3.3 amps @ 12Vą 0.5V @ 21° C (70° F)

A/C Clutch Air Gap 0.35 - 0.60 mm (0.014 - 0.024 in.)
__________________

Thinking of starting a "scammed by" thread? If you sent the paypal as a "gift" don't even bother... no one feels sorry for you.
thepowertowin is offline  
Old 06-19-2006, 04:52 PM   #5 (permalink)
SRTforums Member
 
Join Date: Dec 2002
Member Number: 95
Location: MD
Posts: 106
Default

I'm having the same problem as the op.
hkarpf6045 is offline  
Old 06-19-2006, 04:59 PM   #6 (permalink)
SRTforums Member
 
71ValiantSRT-4's Avatar
 
Join Date: Mar 2005
Member Number: 25339
Location: Indifuckinana
Posts: 6,303
Default

Low on refridgerant. Have it recharged.
71ValiantSRT-4 is offline  
Old 06-19-2006, 06:00 PM   #7 (permalink)
SRTforums Member
 
Bflaker's Avatar
 
Join Date: Jul 2005
Member Number: 30883
Location: Clarksburg, WV
Posts: 1,281
Default

Thanks powertowin. Thats the info I was looking for. Can you get the high pressure switch seperate from the compressor, or is it built into it? I'm about 90% sure thats the problem. Unless something else is telling the PCM to kick the compressor off.
__________________

2003 Acura RSX Type-S: 312whp 256wtq
2005 Dodge Neon SRT-4: 276whp 343wtq(SOLD)
Bflaker is offline  
Old 06-19-2006, 06:55 PM   #8 (permalink)
SRTforums Member
 
cali's Avatar
 
Join Date: Jan 2003
Member Number: 159
Location: On a Rock
Posts: 7,982
Default

Quote: Originally Posted by 71ValiantSRT-4
Low on refridgerant. Have it recharged.

ijiot
__________________
Quote: Originally Posted by Dole Smelly
Just for the record, the torque setting for the oil drain plug is 20 ft-lbs, not infinity.

someone is watching me
cali is offline  
Old 06-20-2006, 07:58 AM   #9 (permalink)
SRTforums Member
 
thepowertowin's Avatar
 
Join Date: Jul 2004
Member Number: 13897
Location: Missouri
Posts: 19,321
Default

Switch is available seperately.

5014574AA switch $28.91 + shipping
__________________

Thinking of starting a "scammed by" thread? If you sent the paypal as a "gift" don't even bother... no one feels sorry for you.
thepowertowin is offline  
Old 06-21-2006, 05:19 AM   #10 (permalink)
SRTforums Member
 
Bflaker's Avatar
 
Join Date: Jul 2005
Member Number: 30883
Location: Clarksburg, WV
Posts: 1,281
Default

Awesome. I still haven't had a chance to get it back in the shop yet. Its got to be one of two things. The high pressure switch or the expansion valve. My dad is leaning more towards the expansion valve, so we'll see.
__________________

2003 Acura RSX Type-S: 312whp 256wtq
2005 Dodge Neon SRT-4: 276whp 343wtq(SOLD)
Bflaker is offline  
Old 06-21-2006, 06:18 AM   #11 (permalink)
SRTforums Member
 
all_bran's Avatar
 
Join Date: Jan 2005
Member Number: 22506
Location: Royal Oak, MI
Posts: 1,703
Default

I have the same problem. When I'm stopped at a stop light I can hear/feel the compressor kick on and off for a few seconds. And immediately can feel warmer humid air coming out the vents. Then it bangs back on and gets cool and dry again

(I have solid motor mounts so when I say BANG I mean it LOL!)
__________________



Black 2004 SRT4 now gone

Black 2007 SRT8 Charger in garage
all_bran is offline  
Old 06-21-2006, 06:25 AM   #12 (permalink)
SRTforums Member
 
Bflaker's Avatar
 
Join Date: Jul 2005
Member Number: 30883
Location: Clarksburg, WV
Posts: 1,281
Default

Thats exactly how mine is. Sometimes when I first start the car, if the AC is on it will kick on so hard it feels like something broke, and if someones in the car with me they look at me like "WTF was that?" I only have ES MM Inserts and it still makes it noticeable.
__________________

2003 Acura RSX Type-S: 312whp 256wtq
2005 Dodge Neon SRT-4: 276whp 343wtq(SOLD)
Bflaker is offline  
Old 06-21-2006, 07:10 AM   #13 (permalink)
SRTforums Member
 
STOCK1SC's Avatar
 
Join Date: Mar 2005
Member Number: 25547
Location: SC
Posts: 1,843
Default

The AC completely went out in my 05 about a month ago and it took a week to get the switch they said I needed in. Must be some bad switches on these 05's maybe. Mine the AC wouldn't even come back on it would just blow the fan. Luckily it was in the 70's a month ago and now it's in the 90's!
__________________
I suppose what we really needed was the president of the United States to be hanging off the side of a helicopter rescuing people that were unable to evacuate, but more than capable of looting all the liquor and electronic stores and paddling away in a canoe.
STOCK1SC is offline  
Old 06-21-2006, 07:19 AM   #14 (permalink)
SRTforums Member
 
all_bran's Avatar
 
Join Date: Jan 2005
Member Number: 22506
Location: Royal Oak, MI
Posts: 1,703
Default

Quote: Originally Posted by Bflaker
Thats exactly how mine is. Sometimes when I first start the car, if the AC is on it will kick on so hard it feels like something broke, and if someones in the car with me they look at me like "WTF was that?" I only have ES MM Inserts and it still makes it noticeable.

Here's a trick I found.

1) Never turn the car off with the AC on. About 45 seconds before you get to your destination, flip the AC off and put the regular fan on HI to blow out all the moisture. This will help reduce any musty smells building up

2) Whenever you want to turn the AC on, take the car out of gear and let the RPMs settle to 900 (idle). THEN flip it on. It's kind of a pain when you're on the highway, but it works. Hardly any loud noises at all. If you do it while you're moving (say 3k RPM down the highway) it'll feel like you hit a deer covered in Quickrete.

Anybody have any suggestions as to why the AC keeps kicking off and back on? It's kind of a pain in REALLY hot weather...
__________________



Black 2004 SRT4 now gone

Black 2007 SRT8 Charger in garage
all_bran is offline  
Old 06-21-2006, 07:20 AM   #15 (permalink)
SRTforums Member
 
all_bran's Avatar
 
Join Date: Jan 2005
Member Number: 22506
Location: Royal Oak, MI
Posts: 1,703
Default

Actually funny story about feeling like I hit a deer covered in Quickrete... I was driving with a buddy of mine, not really paying attention to him. And he sneaks his hand over and flips on the AC without me noticing. BANG!!! Scared the living sh!t out of me! I really thought I hit a medium sized animal...
__________________



Black 2004 SRT4 now gone

Black 2007 SRT8 Charger in garage
all_bran is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 12:24 PM.



(C) SRTforums.com

Search Engine Friendly URLs by vBSEO 3.3.2